The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Unable to login to /webmail & /cpanel

Discussion in 'E-mail Discussions' started by jobokoth, Nov 4, 2004.

  1. jobokoth

    jobokoth Member

    Joined:
    Dec 28, 2001
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Hi people!

    I have encountered a problem after upgrading my server to the latest apache upgrade and the latest cpanel upgrade. All my domains give 500 server errors when I access them through www.domain.com/cpanel or www.domain.com/webmail

    What is the best way to resolve this problem?

    Thanks

    Job
     
  2. arcane

    arcane Member

    Joined:
    Oct 25, 2004
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    Be sure the following are in your httpd.conf:

    ScriptAlias /cpanel /usr/local/cpanel/cgi-sys/redirect.cgi
    ScriptAlias /whm /usr/local/cpanel/cgi-sys/whmredirect.cgi

    I used to have this problem and now it works fine after I readded these lines back to httpd.conf

    I'm not possibly sure but I believe

    ScriptAlias /cpanel /usr/local/cpanel/cgi-sys/webmaillogin.cgi might work for webmail.

    Do a search to verify this for webmail
     
  3. khoonchee

    khoonchee Well-Known Member
    PartnerNOC

    Joined:
    Oct 2, 2002
    Messages:
    134
    Likes Received:
    0
    Trophy Points:
    16
    For webmail , add the following :

    ScriptAlias /webmail /usr/local/cpanel/cgi-sys/wredirect.cgi
     
  4. macooper

    macooper Member

    Joined:
    May 3, 2004
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    I'm not sure why this happened, but after using easyapache to update, I found more than just the /cpanel/ failing. For some reason, all of the ErrorDocument directives had also gone.

    Luckily, I had a backup of the config, so fixing things was easy enough. You might want to check that you have not suffered from the same problem. Heres what I had to add back in to httpd.conf after the last VirtualHost directive:


    HTH,
    Martin
     
  5. WebTrooper

    WebTrooper Member

    Joined:
    Nov 7, 2004
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    I'm having the same problem that started this thread. I checked httpd.conf and sure enough, the ScriptAlias lined are not there. Everything was working fine before I rebuilt Apache via whm. Granted, I can add these lines manually but that should be whm's job, right? I'm assuming I have to reset some self configurating gizmo that writes to httpd.conf, but I can't find any such setting. How do I reset cpanel to add the lines like wots quoted...



    Thanks,
    WebTrooper
     
  6. WebTrooper

    WebTrooper Member

    Joined:
    Nov 7, 2004
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Replying to my own post...

    I found the solution on another thread. I had to put the following lines in httpd.conf and restart Apache


    after ScriptAlias /cgi-bin/ "/usr/local/apache/cgi-bin/"

    I added:

    ScriptAliasMatch ^/cpanel/(.*) /usr/local/cpanel/cgi-sys/redirect.cgi
    ScriptAlias /cpanel /usr/local/cpanel/cgi-sys/redirect.cgi
    ScriptAlias /whm /usr/local/cpanel/cgi-sys/whmredirect.cgi
    ScriptAlias /securewhm /usr/local/cpanel/cgi-sys/swhmredirect.cgi
    ScriptAlias /webmail /usr/local/cpanel/cgi-sys/wredirect.cgi
    ScriptAliasMatch ^/webmail/(.*) /usr/local/cpanel/cgi-sys/wredirect.cgi
    ScriptAlias /controlpanel /usr/local/cpanel/cgi-sys/redirect.cgi
    ScriptAlias /securecontrolpanel /usr/local/cpanel/cgi-sys/sredirect.cgi

    Restarted httpd server from whm and all is well.

    Peace!
     
Loading...

Share This Page