The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

unable to receive email from ex-server

Discussion in 'E-mail Discussions' started by Stanleytiew, Feb 21, 2006.

  1. Stanleytiew

    Stanleytiew Well-Known Member

    Joined:
    May 9, 2005
    Messages:
    143
    Likes Received:
    0
    Trophy Points:
    16
    I have just transfer my account from server A to server B, both are cpanel server and both are running Centos 3.6. After copying all the files from Server A to Server B, I deleted the account from server A. Domain name change are fully propagated and my web site is working well. I can send out email and receive email from anywbody EXCEPT FROM SERVER A. Email send from Server A to Server B will get an error message Internal Server Error and email stay in the outbox of my Microsoft Outlook. Email send from Server B to Server A will be bound back with the error message email address permanent error. I have root access for both server. Please help.
     
  2. brianoz

    brianoz Well-Known Member

    Joined:
    Mar 13, 2004
    Messages:
    1,146
    Likes Received:
    6
    Trophy Points:
    38
    Location:
    Melbourne, Australia
    cPanel Access Level:
    Root Administrator
    Sounds like your problem is that your emails are being delivered to the domains on the old server.

    Remove the old domains from the /etc/localhosts and put them in the /etc/remotehost file.
     
  3. Stanleytiew

    Stanleytiew Well-Known Member

    Joined:
    May 9, 2005
    Messages:
    143
    Likes Received:
    0
    Trophy Points:
    16
    There is no /etc/localhosts and /etc/remotehost in my /etc folder. I found /etc/localdomains but the domain name is not in the list.
     
  4. brianoz

    brianoz Well-Known Member

    Joined:
    Mar 13, 2004
    Messages:
    1,146
    Likes Received:
    6
    Trophy Points:
    38
    Location:
    Melbourne, Australia
    cPanel Access Level:
    Root Administrator
    Sorry ... its localdomains and remotedomains, both in /etc.

    Not sure why they don't exist, that does sound broken. I'd definitely start by just deleting the old domains from the ex-server, that should enable you to email them.
     
  5. Stanleytiew

    Stanleytiew Well-Known Member

    Joined:
    May 9, 2005
    Messages:
    143
    Likes Received:
    0
    Trophy Points:
    16
    I think the domains had been remove from /etc/localdomains when I deleted the domain from WHM. Normally it will work after removing it from ex-server but in this case it doesn't work. Now I found out something, the domain that failed is the parked domain. Is there any setting that I miss out
     
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Do you have the domains on the old server still listed with old IP's on that server in the zone files in /var/named/* and the server using itself for DNS resolution in /etc/resolv.conf? If so, that could be one possible reason.
     
  7. Stanleytiew

    Stanleytiew Well-Known Member

    Joined:
    May 9, 2005
    Messages:
    143
    Likes Received:
    0
    Trophy Points:
    16
    /var/named/* is clean and /etc/resolv.conf is not using this domain name.

    The domain that doesn't work is parked domain.
     
Loading...

Share This Page