The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Unable to remove accounts. usermod error: unknown group ""

Discussion in 'General Discussion' started by nat, Apr 10, 2004.

  1. nat

    nat Well-Known Member

    Joined:
    Jan 16, 2003
    Messages:
    204
    Likes Received:
    0
    Trophy Points:
    16
    I got a new server. I have been unable to remove accounts using WebHost Manager from this server from day 1.

    I thought they were being removed but WebHost manager does not delete the home directories or remove the users from the passwd and shadow files.

    Everything else is done but that.

    I have upgraded cpanel and webhost manager to latest and rebooted. It has not helped. I tried removing the users from the groups manually in order to delete the users and the groups but I get this error: usermod: unknown group ""

    /usr/sbin/usermod -g usersnamehere -G \"\" usersnamehere
    usermod: unknown group ""


    WHM 9.1.0 cPanel 9.1.0-S93
    RedHat Enterprise 3 - WHM X v2.1.2
     
  2. hotice007

    hotice007 Well-Known Member
    PartnerNOC

    Joined:
    Jun 20, 2002
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    Remove them from /etc/group file and that should do it.
     
  3. nat

    nat Well-Known Member

    Joined:
    Jan 16, 2003
    Messages:
    204
    Likes Received:
    0
    Trophy Points:
    16
    That would not have fixed it completly as everytime I deleted an account using WebHost Manager it would leave that and other files on the server.

    I did manage to delete all of the accounts that were not deleted in the pass using what you said. - Thanks.
     
    #3 nat, Dec 16, 2004
    Last edited: Dec 16, 2004
  4. nat

    nat Well-Known Member

    Joined:
    Jan 16, 2003
    Messages:
    204
    Likes Received:
    0
    Trophy Points:
    16
    For other people with the same issue...

    This was fixed by contacting cpanel support. They said "we ran some updates on the server."

    Accounts deleted with WebHost Manager would be deleted completly from then on.
     
    #4 nat, Dec 16, 2004
    Last edited: Dec 16, 2004
Loading...

Share This Page