SOLVED Unable to send email from GoDaddy VPS

qkgm828

Member
Jan 22, 2016
5
2
1
dallas
cPanel Access Level
Root Administrator
I have 2 VPS and i installed cPanel and WHM.

CENTOS 7.6 virtuozzo [s13x-14x-13x-13x]


[Moderator Note: Removed the hostname from the version output here]
v80.0.22

Both VPS have same issue.

My customers in VPS can not send emails. but they can receive emails.

I checked my customer's log. there is no error log in
/var/cpanel/roundcube/log
/var/cpanel/horde


They got bounce back emails like below.


Code:
Mail delivery failed: returning message to sender

This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

[email protected]
retry timeout exceeded
Reporting-MTA: dns; s13x-14x-13x-13x.secureserver.tld

Action: failed
Final-Recipient: rfc822;[email protected]
Status: 5.0.0
can you give me an solution or direction to solve?

thanks and have a good one.
 
Last edited by a moderator:

keat63

Well-Known Member
Nov 20, 2014
1,312
92
28
cPanel Access Level
Root Administrator
I see that you are a new poster, so I'll be presumptious and assume that these are new installtions ?

If so, has rDNS been configured with your VPS provider.
This is something that will need to be performed with your server providers, and not on your own VPS.

Also maybe have a play around with MXToolbox.com, this has lots of tools to help try and figure out the problem.
 

qkgm828

Member
Jan 22, 2016
5
2
1
dallas
cPanel Access Level
Root Administrator
Thanks all.

I asked about rDNS to godaddy.

Godaddy said rDNS is configured on all our email servers. However, we do not allow customers to setup custom rDNS records on any hosting plan (shared or server).

and he gave me a hint to solve this problem like below.

"You will need to configure the email servers properly. All of our servers use dedrelay.secureserver.net."

so i find postfix. but he said

"Since you are using cPanel, you should Exim instead of postfix"

please let me know how to configure the email servers properly with Exim.
 

keat63

Well-Known Member
Nov 20, 2014
1,312
92
28
cPanel Access Level
Root Administrator
I'll be brutally honest, this is the sort of response I've seen before from them.
The irony of this, is from what I've read, postfix is installed by default on a GoDaddy VPS.

This might help
seo-gold.com/godaddy-vps-dedicated-servers-not-sending-email-to-gmail-hotmail-etc/
 
Last edited by a moderator:

qkgm828

Member
Jan 22, 2016
5
2
1
dallas
cPanel Access Level
Root Administrator
I'll be brutally honest, this is the sort of response I've seen before from them.
The irony of this, is from what I've read, postfix is installed by default on a GoDaddy VPS.

This might help
seo-gold.com/godaddy-vps-dedicated-servers-not-sending-email-to-gmail-hotmail-etc/
Thanks keat63.

i tried to find main.cf file in etc/postfix. but i could find that file.

is there a paid service in cPanel?
 

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,749
2,205
363
cPanel Access Level
DataCenter Provider
Twitter
Hello @qkgm828,

My understanding is that you should first browse to WHM >> Exim Configuration Manager >> Basic Editor and click on the Mail tab. Then, scroll down to the option named Smarthost support, enter the value your hosting provider shared with you (e.g. dedrelay.secureserver.net), then scroll to the bottom to click Save.

Thank you.
 
  • Like
Reactions: keat63

qkgm828

Member
Jan 22, 2016
5
2
1
dallas
cPanel Access Level
Root Administrator
Hello @qkgm828,

My understanding is that you should first browse to WHM >> Exim Configuration Manager >> Basic Editor and click on the Mail tab. Then, scroll down to the option named Smarthost support, enter the value your hosting provider shared with you (e.g. dedrelay.secureserver.net), then scroll to the bottom to click Save.

Thank you.
Thanks...you gave me a right direction :)

i solved this problem....

have a good one.