The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Unable to send email

Discussion in 'E-mail Discussions' started by yanes, Jul 25, 2007.

  1. yanes

    yanes Registered

    Joined:
    Jul 25, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    My ISP has blocked smtp port 25 and I am now unable to send email, however i can recieve my email, Does anyone have a fix.....I have asked tech support at comcast and they have not come up with an answer quite yet.
     
  2. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,279
    Likes Received:
    36
    Trophy Points:
    48
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    A few options...

    Find out from your domain webhost if they have an alternative SMTP port that you can use for sending mail. Many web hosts provide a separate port from Port 25 that you can connect to in order to send your mail. It may be port 26 or it may be some other port of your webhost's choosing. If you're on a Cpanel server, your webhost can easily enable Exim to listen on an additional port besides port 25, if they haven't done so already. Ask them.

    Another option is to use Comcast's SMTP server for sending mail. There really is no reason why you couldn't/shouldn't do this if your webhost doesn't provide an additional SMTP port.

    To do this you would specify your Comcast's SMTP server as the SMTP server in your email client configuration. Then you would enable SMTP Authentication in your email client. But you'll also need to tell your email client to use your Comcast email login/password to authenticate into the SMTP server when sending.

    A typical setup may be something like this:

    your domain: mydomain.com
    pop3 server; mail.mydomain.com
    smtp server: <comcast smtp server goes here>

    - enable SMTP authentication in your email client - tell it to use specific login credentials that you provide instead of using the pop3 login/password. Then you would specify youremail@comcast.net and the password associated with that account in your SMTP auth.

    So when you receive mail you'd be receiving it from mail.yourdomain.com. And when you send mail it would be sent to comcast's server for further delivery. And they would allow this as long as your email client SMTP authenticates into their mail server with a valid comcast email address/password.

    Mike
     
  3. yanes

    yanes Registered

    Joined:
    Jul 25, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Thank You

    The change from port 25 to 26 took care of the problem........thank you
     
  4. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,279
    Likes Received:
    36
    Trophy Points:
    48
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    You're welcome :)

    Mike
     
  5. Bailey

    Bailey Well-Known Member

    Joined:
    Aug 12, 2001
    Messages:
    120
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Wisconsin
    Incidentally, for Charter Business customers... Charter blocks port 26 on their business accounts :( but port 28 is open and works great for this purpose.

    Just posting this in case some distraught Charter customer comes along looking for help in the future. :)

    :D Bailey
     
Loading...

Share This Page