The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

unable to send mail

Discussion in 'E-mail Discussions' started by ehpsubrat, Apr 17, 2004.

  1. ehpsubrat

    ehpsubrat Member

    Joined:
    Dec 19, 2003
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    India
    I am not able to receive any mail. While sending mail I am getting the error.

    Recipient error [451 Temporary local problem - please try later]

    I am able to send mail using webmail. I am not able to send mail from mail client nor I am able to receive.
     
    #1 ehpsubrat, Apr 17, 2004
    Last edited: Apr 17, 2004
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Have you checked your server logs to see if they are reporting the problem:

    /var/log/exim_mainlog
     
  3. ehpsubrat

    ehpsubrat Member

    Joined:
    Dec 19, 2003
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    India
    while I am sending mail i am getting error

    2004-04-17 14:12:10 H=(server144.nlservices.com) [69.72.130.50]:36964 F=<info@houstonraves.com> rejected RCPT <kevin@breaksnation.com>: (server144.nlservices.com) [69.72.130.50]:36964 is currently not permitted to relay through this server. Perhaps you have not logged into the pop/imap server in the last 30 minutes or do not have SMTP Authentication turned on in your email client.
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Are you actually accessing your account by POP3 just before sending, because that is what that error is saying you need to do. This is to authenticate you for sending email through the server.

    It could be that antirelayd is not running. You can check this with:

    ps axf| grep -v grep | grep antirelayd

    It should show a running process. It is this process that maintains the file /etc/relayhosts where the IP addresses of people who have accessed their accounts by POP3 are stored for 30 minutes each.

    You can also place your IP address in /etc/alwaysrelay and this will then allow you to always send email without having to POP first. Though this is not preferred as it can open security risks. IT would be better to use SMTP AUTH in your email client.
     
  5. ehpsubrat

    ehpsubrat Member

    Joined:
    Dec 19, 2003
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    India
    Run that command
    added the IP in the /etc/alwaysrelay
    restarted the exim
    still same problem. authentication tab is already enabled.
     
  6. ehpsubrat

    ehpsubrat Member

    Joined:
    Dec 19, 2003
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    India
    solution found

    the domain name houstonraves.com was missing in the /etc/localdomains
    just added that domain name in the file and it workd fine.
     
  7. kman

    kman Member

    Joined:
    Aug 18, 2003
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    well a couple domains were magically disappeared
    from my /etc/localdomains too! anybody knows how
    did that happen?
     
  8. ehpsubrat

    ehpsubrat Member

    Joined:
    Dec 19, 2003
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    India
    If you are missing the /etc/localdomains entry then run the script

    /scripts/updateuserdomains

    this will fix the problem.
     
Loading...

Share This Page