Unable to send or receive external mail

Mark Garlick

Member
Oct 26, 2015
6
1
3
United Kingdom
cPanel Access Level
Root Administrator
Hi,

Got a bit of a strange problem. Up until late last week we had no issues suddenly we are unable to send or receive email externally. Just get an unknown server error. Hosting company are looking into it but with no progress yet. Had to temporarily disable exim and dovecote and when restarting in whm following log is generated.

Any bright ideas would be gratefully received!


Oct 23 10:15:33 server dovecot: master: Dovecot v2.2.16 starting up for imap, pop3 (core dumps disabled)
Oct 23 10:15:33 server dovecot: log: Warning: Killed with signal 15 (by pid=2815 uid=0 code=kill)
Oct 23 10:15:33 server dovecot: imap-login: Error: read(anvil) failed: EOF
Oct 23 10:15:33 server dovecot: auth: Error: net_connect_unix(anvil-auth-penalty) failed: Permission denied
Oct 23 10:15:33 server dovecot: auth: Error: read(anvil-auth-penalty) failed: EOF

dovecot restarted successfully.

Waiting for “imap” to restart ……………………waiting for “imap” to initialize ……
…finished.

Service Status
dovecot (/usr/sbin/dovecot) is running as root with PID 2876 (pidfile check method).

The service “imap” failed to start with the message: The 'dovecot' service passed the check.

Startup Log
Starting Dovecot Imap: [ OK ]

imap has failed. Please contact your system administrator if the service does not automagically recover.

Service Changes Complete Log Messages
 

Daniel Boris

Member
Sep 29, 2015
9
1
3
Montpellier
cPanel Access Level
Root Administrator
I have the same problem, e-mails only work internally but cannot receive or send emails to/from any other domain than my own. Only difference is, I have never been able to get it working properly once.

Perhaps any recommendations from experienced user on debugging would be highly appreciated?
 
  • Like
Reactions: Mark Garlick

Infopro

Well-Known Member
May 20, 2003
17,113
507
613
Pennsylvania
cPanel Access Level
Root Administrator
Twitter
Had to temporarily disable exim and dovecote and when restarting in whm following log is generated.
What do you mean by "disable exim and dovecot" exactly? If you disabled it and tried to restarted a disabled service, I would think those errors would be expected?

If I disable EXIM from Service Manager, and then go to Restart Services and try to restart EXIM I only get this message:
The “exim” service is disabled.
 

Mark Garlick

Member
Oct 26, 2015
6
1
3
United Kingdom
cPanel Access Level
Root Administrator
What do you mean by "disable exim and dovecot" exactly? If you disabled it and tried to restarted a disabled service, I would think those errors would be expected?

If I disable EXIM from Service Manager, and then go to Restart Services and try to restart EXIM I only get this message:
I disabled the following in the service manager:
Exim Mail server
IMAP Server (Dovecote pop3)
POP 3 server.

Did what need to be done and then re-enabled them which then produced the above log error!
 

Mark Garlick

Member
Oct 26, 2015
6
1
3
United Kingdom
cPanel Access Level
Root Administrator
I'm sorry, I can't make out what your reply means.
Sorry trying to do too much at once...

I was going to make a copy mail folder as was running low on space.. purchased additional storage from hosting company (to accommodate the copy) but but turns out that the new partition of extra space had not been set up/mounted correctly... hence gave up with the idea of speaking to them the following day and so re enabled the services stated above!
 

Mark Garlick

Member
Oct 26, 2015
6
1
3
United Kingdom
cPanel Access Level
Root Administrator
Can't hurt to give that a go while you wait. cPanel updates checks and fixes things. Can it help here? Not sure, but trying a forced update won't make things worse I don't think. ;)
Pleased to say... all up and running again! Hosting company not huge help.. ran mail permissions repair in whm (few that were incorrect it would seem) and also cpanel update! :) thanks for the suggestions!
 
  • Like
Reactions: Infopro