The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

unable to setuids via ssh

Discussion in 'General Discussion' started by Secret Agent, Apr 11, 2006.

  1. Secret Agent

    Secret Agent Guest

    Anytime a client tries to ssh in to his account, he gets this message before getting disconnected

    "unable to setuids"

    I am able to duplicate this. Their account has jailed shell enabled. I do not get this on my admin / wheelgroup accounts otherwise.

    Any ideas?

    I installed systat via rpm (as iostats was down). Probably has nothing to do with this as it obviously didn't resolve the issue :D
     
  2. Secret Agent

    Secret Agent Guest

    Anyone know about this?

    One more question in the meantime;

    Is there any way for a client to directly edit his Exim filter file directly from bash without using CPanel?
     
  3. Secret Agent

    Secret Agent Guest

    Regarding the EXIM filter for domains

    I'm referring to /etc/vfilters directory, there's 1 file for each domain on the shared machine.

    I believe (although I am not sure exactly about how you have configured chroot) that
    "ln -s /etc/vfilters/domain.com /home/artistic/vfilters.domain.com"
    would do the trick. Correct?
     
  4. randomuser

    randomuser Well-Known Member

    Joined:
    Jun 25, 2005
    Messages:
    147
    Likes Received:
    0
    Trophy Points:
    16
    I've seen a similiar issue on a customer's VDS server after he enabled "shell fork bomb protection" from within WHM. Do you have that enabled?
     
  5. Secret Agent

    Secret Agent Guest

    This is happening again.

    I tried with and without shell fork bomb protection on and off, same problem as explained below:

    Port 22002
    Protocol 2
    ListenAddress xxx.xxx.67.52
    #ListenAddress ::

    #LoginGraceTime 2m
    PermitRootLogin no
    #StrictModes yes
    #MaxAuthTries 6


    "sshd has failed, please contact the sysadmin."

    I can login via the wheel user/pw but it gives invalid root password when I "su -" into root mode, yet the same root works for whm without a problem.

    /dev/null is chmodded 666 also
     
Loading...

Share This Page