Unable to upgrade wordpress from within cPanel

smoundzou

Registered
May 30, 2017
1
0
1
Tennessee
cPanel Access Level
Root Administrator
I am unable to upgrade wordpress from within cpanel.

I am using:
  • CENTOS 6.9 x86_64 virtuozzo – server
  • cPanel & WHM 64.0 (build 24)
the wordpress version is, V392

Here is the message I am getting:
Code:
Warning: The plugin “cPanel & WHM® Site Software” could not be activated
The system could not copy the “/home/kinglawf/public_html/wp-content/plugins/akismet/views/strict.php” folder to working folder “./wp-content/plugins/akismet/views/strict.php”.
[B]Error:[/B] The system could not prepare the working directory:
Any help would be appreciated.

Thanks
 
Last edited by a moderator:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,222
463
The system could not copy the “/home/kinglawf/public_html/wp-content/plugins/akismet/views/strict.php” folder to working folder “./wp-content/plugins/akismet/views/strict.php”.
Hello,

I've seen this happen when the wp-content/plugins/akismet/views/strict.php file is missing from the account. Could you verify if that file is missing, and if so, try restoring it from any available backups you have stored for this account?

Otherwise, here's a quote from one of our Analysts responding to a similar issue:

What I did to replace the missing /wp-content/plugins/akismet/views/strict.php file was:

1) Looked in /home/$username/public_html/wp-includes/version.php and found the WordPress version (4.7.2).
2) Downloaded WordPress 4.7.2 from the WordPress archive: wget https://wordpress.org/wordpress-4.7.2.zip
3) Extracted it and copied /root/cptechs/wordpress/wp-content/plugins/akismet/views/strict.php to /home/$username/public_html/wp-content/plugins/akismet/views. I made sure the permission and ownership on strict.php was set correctly.
4) Attempted to upgrade the WordPress instance, I get a new error now:

===

Upgrading $username cPanel::Blogs::WordPress.0.yaml installation here...
Error: The system could not apply the /usr/local/cpanel/cpaddons/cPanel/Blogs/WordPress/upgrade/4.7.2_4.7.3/diff patch and returned the following error code: 1
Error: You modified this cPAddon or the upgrade test failed. You cannot update this cPAddon via this interface.
To force the upgrade, type the following in to the form below:

Error: You modified this cPAddon or the upgrade test failed. You cannot update this cPaddon via this interface.
For technical reasons, you can only attempt a forced upgrade via cPanel when logged in as the user with the user's password.

===

What I advise doing is backing up the '$username' account and logging into the cPanel area for the account (using the user/password for the actual account). Then go under Site Software and force an upgrade on the WordPress instance. It appears what it's trying to patch shouldn't cause any issues if you forcefully upgrade.
Thank you.