Undefined catalog: /~fciperfo/cgi-bin/cart.cgi

brianteeter

Well-Known Member
Jan 6, 2002
72
0
306
Is there any way to fix these Undefined catalog errors short of removing and reinstalling the shopping cart?

They just seem to pop up over and over and I don't want to delete the customer's store just to &fix& the problem.

Any advice? I'm on the latest CPanel build, just did /scripts/upcp

Thanks in advance,

Brian
 

Curious Too

Well-Known Member
Aug 31, 2001
428
1
318
cPanel Access Level
Root Administrator
[quote:8feecd2444][i:8feecd2444]Originally posted by brianteeter[/i:8feecd2444]

Is there any way to fix these Undefined catalog errors short of removing and reinstalling the shopping cart?

They just seem to pop up over and over and I don't want to delete the customer's store just to &fix& the problem.

Any advice? I'm on the latest CPanel build, just did /scripts/upcp

Thanks in advance,

Brian[/quote:8feecd2444]

Did you try /scripts/rebuildinterchangecfg ?
 

brianteeter

Well-Known Member
Jan 6, 2002
72
0
306
[quote:349a635e9d][i:349a635e9d]Originally posted by Curious Too[/i:349a635e9d]


Did you try /scripts/rebuildinterchangecfg ?[/quote:349a635e9d]

No, I actually fixed it by hand by editing interchange.cfg - but that script is handy. Thanks for the info. It'll save me some time next time this happens. :)

Thanks - Brian
 

jsteel

Well-Known Member
Jul 4, 2002
646
0
166
Atlanta, GA
I've been getting this error a lot lately. something seems to happen to IC as a whole - all carts return that error. A simple restart of IC fixes it, but it is becoming a major hassle (multiple times today). The chkserv daemon seems to think everything is fine even though customers can't actually access their carts.

This really needs to be resolved.

Jaz