undefined Email User added and can't be deleted

zaph

Registered
Feb 3, 2010
4
0
51
Hi all,

When adding the first mail account to a domain in CPanel 11.28.64 (CentOS 5.5 i686) I'm running into a problem where it's adding a user called "undefined" with a Usage/Quota of "NaN / undefined MB" - as well as adding the user requested. The undefined user can not be deleted, pressing Delete does nothing.

Any ideas?
 

JaredR.

Well-Known Member
Feb 25, 2010
1,834
25
143
Houston, TX
cPanel Access Level
Root Administrator
Watch the cPanel error log while you try to delete the mailbox. Run the following command from the shell as root:

Code:
# tail -f /usr/local/cpanel/logs/error_log
and try to delete the mailbox. If any error is generated, please paste it into this thread. Use Ctrl+C to stop the tail command and return to the command prompt.

What you describe is an unusual situation, so it will be best if you can submit a ticket so that we may log into your server and investigate it directly and fix it for you.
 

zaph

Registered
Feb 3, 2010
4
0
51
We've put in a ticket with CPanelSource.

In our case it seems to happen on all domains, whether the plan is changed, or whether it's a freshly created domain with nothing changed.

Here's a screenshot of the accounts list afterwards.
undefined_ss.jpg


Watch the cPanel error log while you try to delete the mailbox. Run the following command from the shell as root: and try to delete the mailbox.
The Delete link doesn't actually do anything. Normally when you click is has the Delete and Cancel choices pop under, but it doesn't in this case.


The other thing that happens is - when you add the first user, it adds it no problem, but you have to reload the page to see the updated list. Adding subsequent users works as expected, with them showing up as soon as they are added. Maybe there's an issue with the AJAX code when adding the first user?

Is the AJAX browser platform-specific at all? I'm on a Mac (Safari & Firefox).
 

rodeoXtreme

Registered
Jun 16, 2007
3
0
51
Hello,

We are having the same issue, I have not found anything in the error log and cannot delete it. When I create an account from any cPanel account it runs "...creating account.." but never stops; if I click on the add / remove email the account is created but cannot delete them. We are using WHM (WHM 11.28.64).
 

cPanelDon

cPanel Quality Assurance Analyst
Staff member
Nov 5, 2008
2,544
12
268
Houston, Texas, U.S.A.
cPanel Access Level
DataCenter Provider
Twitter
We have the same problem.
Any solutions?
Hello,

We are having the same issue, I have not found anything in the error log and cannot delete it. When I create an account from any cPanel account it runs "...creating account.." but never stops; if I click on the add / remove email the account is created but cannot delete them. We are using WHM (WHM 11.28.64).
Please submit a support request so that we can take a closer look at the affected systems; direct access will be needed in order to accurately diagnose the issue and determine an appropriate resolution. When available, please post your ticket ID number so that we may follow-up internally. Thank you. :)
 

JaredR.

Well-Known Member
Feb 25, 2010
1,834
25
143
Houston, TX
cPanel Access Level
Root Administrator
Please submit a ticket so that we may log into the affected system(s) and investigate directly. It is very difficult to do anything other than speculate without access to a server that is exhibiting the problem. There is no charge for submitting a complimentary support request to us.
 

imercosul

Registered
May 31, 2003
1
0
151
Brasil
The same problem we have here in one server upgraded yesterday. No solution found for the issue.

Please, share the solution for this problem here in the forum.

This kind of problem, specially with emails, is very bad. The costumer do not understand such issues. We think the CPanel upgrades must be better and more tested before release them to avoid such issues.

The common sense is that a STABLE version of a product is sufficiently tested to avoid the big problems like this one.
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
41
348
somewhere over the rainbow
cPanel Access Level
Root Administrator
Can you please open a ticket to WHM > Support Center > Contact cPanel or using the link in my signature. Also, please post your cPanel version:

Code:
cat /usr/local/cpanel/version
Finally, what browser are you using? There is an older case I found in our system from last year about IE7 and IE8 having this occur, but this would have been fixed last year.
 

devendradb

Member
May 8, 2010
18
0
51
Mumbai, India
Hi,
I don't know the reason why this happens but try running this php script from front end without logging into cPanel and just see what it does on cPanel email list. replace the variable values which suits you.

Code:
<?php
$path="http://$cpuser:[email protected]$cpdomain:2082/frontend/$cpskin/mail/doaddpop.html?&quota=$quota&email=$email&domain=$cpdomain&password=$pass";
$f = fopen($path,"r");
?>
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
41
348
somewhere over the rainbow
cPanel Access Level
Root Administrator
It appears that STRIKE's ticket was resolved simply by an analyst running /scripts/upcp --force on the machine. Possibly this was due to some theme file not properly having updated in normal cPanel updates previously.
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
41
348
somewhere over the rainbow
cPanel Access Level
Root Administrator
Have you run a forced cPanel update as was advised previously? Simply issue the command in root SSH:

Code:
/scripts/upcp --force
Thanks.