Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Unexpected condition from IMAP server

Discussion in 'E-mail Discussions' started by abdelhost77, Jan 8, 2018.

  1. abdelhost77

    abdelhost77 Well-Known Member

    Joined:
    Apr 25, 2012
    Messages:
    98
    Likes Received:
    2
    Trophy Points:
    58
    cPanel Access Level:
    Root Administrator
    Hello ,

    Im finding a big issue on all cpanel accounts , they cannot use webmail ( roundcube )

    error on roundcube :

    Unexpected condition from IMAP server, closed or corrupt connection to IMAP. Possible mailbox corruption.


    I found on log :

    [08-Jan-2018 19:18:41 Europe/Berlin] Unexpected condition from IMAP server, closed or corrupt connection to IMAP. Possible mailbox corruption.
    [08-Jan-2018 19:18:41 Europe/Berlin] PHP Warning: fclose() expects parameter 1 to be resource, null given in /usr/local/cpanel/base/3rdparty/roundcube/program/lib/Roundcube/rcube_imap_generic.php on line 226


    in /var/cpanel/roundcube/log/errors


    Please help
     
  2. abdelhost77

    abdelhost77 Well-Known Member

    Joined:
    Apr 25, 2012
    Messages:
    98
    Likes Received:
    2
    Trophy Points:
    58
    cPanel Access Level:
    Root Administrator
    we have also this error :

    [08-Jan-2018 18:47:22 +0100]: <881uma8o> DB Error: [1062] Duplicate entry '881uma8o82v7p8i6jdil3vofq4' for key 'PRIMARY' (SQL Query: INSERT INTO `session` (`sess_id`, `vars`, `ip`, `changed`) VALUES ('881uma8o82v7p8i6jdil3vofq4', 'bGFuZ3VhZ2V8czo1OiJmcl9GUiI7dGVtcHxiOjE7c2tpbnxzOjU6ImxhcnJ5Ijs=', 'x.x.x.x, now())) in /usr/local/cpanel/base/3rdparty/roundcube/program/lib/Roundcube/rcube_db.php on line 543 (GET /cpsess7193926569/3rdparty/roundcube/index.php)
     
  3. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    15,996
    Likes Received:
    339
    Trophy Points:
    433
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
  4. abdelhost77

    abdelhost77 Well-Known Member

    Joined:
    Apr 25, 2012
    Messages:
    98
    Likes Received:
    2
    Trophy Points:
    58
    cPanel Access Level:
    Root Administrator
    i launch :

    /scripts/remove_dovecot_index_files -all

    but it does not resolve the issue :(
     
  5. abdelhost77

    abdelhost77 Well-Known Member

    Joined:
    Apr 25, 2012
    Messages:
    98
    Likes Received:
    2
    Trophy Points:
    58
    cPanel Access Level:
    Root Administrator
    Increasing WHM Home » Service Configuration » Mailserver Configuration" "Maximum Number of Mail Processes" to 1024 does not either resolve the issue .
    In fact when i restart IMAP it work for sometimes , then the problem reoccur , actually we have :
    ps aux | grep [d]ove | wc -l
    42
    Any help please ?

    EDIT : i just stop the firewall CSF & LFD and it works again , could you please indicate which port , service or modification should i do on the firewall CSF & LFD that will keep IMAP working? because i need the firewall to be activated .
     
    #5 abdelhost77, Jan 8, 2018
    Last edited: Jan 8, 2018
  6. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    15,996
    Likes Received:
    339
    Trophy Points:
    433
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
Loading...

Share This Page