The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

"Unresolvable chain of dependencies" squirrelmail

Discussion in 'E-mail Discussions' started by Vatoloco, Aug 5, 2005.

  1. Vatoloco

    Vatoloco Well-Known Member

    Joined:
    Jun 21, 2004
    Messages:
    100
    Likes Received:
    0
    Trophy Points:
    16
    In /scripts/upcp I am suddenly getting this message:

    Unresolvable chain of dependencies:
    squirrelmail-1.4.3a-10.EL3 requires php >= 4.0.4

    Is it basically saying I have to upgrade to php 4.0.4? Squirrelmail is working fine as is so I don't know why I would want to upgrade php.
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    I would suggest that you exclude squirrelmail from your OS update procedure since cPanel provides their own install and you should not be installing/updating the OS provided version.
     
  3. Vatoloco

    Vatoloco Well-Known Member

    Joined:
    Jun 21, 2004
    Messages:
    100
    Likes Received:
    0
    Trophy Points:
    16
    Thanks! It took me a minute to figure out where that was (up2date --config for anyone that's wondering).

    I set my skip list to this:

    squirrelmail*;kernel*;spamassassin*;httpd*;perl*;mysql*;php*;mod_ssl*;imap*;spamassassin*;caching-nameserver*;

    I found another post here where that was suggested. The only thing in their that wasn't already default on mine was squirrelmail, spamassassin and caching-nameserver. I'm not even using spamassassin nor do I have my own nameservers setup so I figured it was okay to skip those.
     

Share This Page