Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Unroutable address

Discussion in 'E-mail Discussion' started by jwhitesell, Sep 17, 2018.

  1. jwhitesell

    jwhitesell Registered

    Joined:
    Oct 3, 2011
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    51
    cPanel Access Level:
    Root Administrator
    I've run into an email deliverability issue I've never seen before. When trying to send mail from an account the mail is rejected by the remote server with the following messages:


    SMTP error from remote mail server after MAIL FROM:<xxx@xxxx.com> SIZE=61649:
    550-Verification failed for <xxx@xxxx.com>
    550-Unrouteable address
    550 Invalid sender <xxx@xxxxx.com>


    I've got SPF and DKIM set up correctly. All deliverability tests I run find no issues.

    The recipient's provider said this to their client:
    "They have disabled "Allow empty sender address" in the SMTP/AntiSpam
    settings. This setting is enabled by default. "

    I've looked through the EXIM settings and if there is a setting like that I've missed it.

    Any insight into how to solve this? Thanks!
     
  2. jwhitesell

    jwhitesell Registered

    Joined:
    Oct 3, 2011
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    51
    cPanel Access Level:
    Root Administrator
    And to expand on this... the address on my server that is being rejected by the remote server IS set up correctly on my server and has no issues with any other external addresses except those hosted by this one provider.

    What could cause this valid address on my server to fail an SMTP callout verification? It appears to succeed when I try it.

     
  3. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    6,260
    Likes Received:
    480
    Trophy Points:
    233
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hello @jwhitesell

    This isn't an exim setting which is why you're not finding it. This is a setting that is specific to the recipient's Anti-SPAM configuration. While more than likely the issue is a sender verification lookup failed due to some configuration issue on the remote server, Per RFC requirements Empty senders must be allowed. This is noted in exim's documentation Exim Specification - 45. Verification of incoming mail and discussed in RFC 1123 - Requirements for Internet Hosts - Application and Support of the RFC documentation.



    This is an issue that needs to be addressed on the remote server, it cannot be addressed on your server.

    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice