The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Unroutable mail issues

Discussion in 'E-mail Discussions' started by siouxsie, Jun 29, 2005.

  1. siouxsie

    siouxsie BANNED

    Joined:
    Jun 18, 2005
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    0
    We are still seeing lots and lots of unroutable mail issues on domains we know are valid.

    What is the story on this issue and when will it be fixed once and for all?

    2005-06-29 01:25:08 H=abo-119-97-68.mrs.modulonet.fr [85.68.97.119] sender verify fail for <nthwhpc@prodigy.com>: unrouteable mail domain "prodigy.com"
     
  2. ngchandak

    ngchandak Well-Known Member

    Joined:
    Apr 5, 2005
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    India
    To stop the unroutable mails you have to set :fail: in default address of mail. This may help you from unroutable mails.
     
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    AFAIK, there's no problem with unroutable mail other than incorrectly configured servers. IF you don't want to do sender verification, turn it off in WHM. If you do, then you need to ensure that your server is quickly and correctly resolving domains locally. The nunroutable error means exactly that, exim has tried to route an email and was unable to for some technical reason.
     
  4. siouxsie

    siouxsie BANNED

    Joined:
    Jun 18, 2005
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    0
    Our server is configured properly. Our DNS is also configured properly. Where do you suggest i look for a check?
     
  5. easyhoster1

    easyhoster1 Well-Known Member

    Joined:
    Sep 25, 2003
    Messages:
    659
    Likes Received:
    0
    Trophy Points:
    16
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Well spotted ;)
     
  7. sparek-3

    sparek-3 Well-Known Member

    Joined:
    Aug 10, 2002
    Messages:
    1,381
    Likes Received:
    23
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    You will get an unroutable mail domain error if that user has exceeded the maximum number of outgoing e-mails that you have setup through your WHM. I'm not sure if that is the case in this particular scenerio, but it is something that you might want to look into.
     
  8. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Indeed, although the exim logs should indicate that it was for exceeding that limit.
     
  9. power_on

    power_on Member

    Joined:
    Aug 10, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Finally I got the solution.

    Cpanel support staff resolve it for me "The presence of /etc/eximmailtrap was causing the issue with webmail
    not sending out. I removed this file and this appears to be working now"

    so gust remove /etc/eximmailtrap and restart Exim.

    :)

    Regards.
     
  10. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    If you do that you should also edit /var/cpanel/cpanel.config and set eximmailtrap=0 otherwise that file will be recreated whenever you save anything in WHM > Tweak Settings.
     
  11. fusioncroc

    fusioncroc Well-Known Member

    Joined:
    Sep 28, 2004
    Messages:
    261
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    U.K.
    I have the same issue here, except that was already disabled and I removed the file and restarted.
    To no avail.
    Sorry for cross posting though, just thought this thread was more appropiate.
     
  12. fusioncroc

    fusioncroc Well-Known Member

    Joined:
    Sep 28, 2004
    Messages:
    261
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    U.K.
    Works now, after I disabled LES quickly... could be due to the RPM database locked or maybe some binaries having in-compatiable permissions.
    That is another thing to look out for.
     
  13. denisdekat09

    denisdekat09 Well-Known Member

    Joined:
    Mar 2, 2002
    Messages:
    265
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    San Francisco
    I have one server that gets unroutable also:

    root@secure06 [/etc]# sendmail -bv cindyambanta@iig-insurance.com
    cindyambanta@iig-insurance.com failed to verify:
    Unrouteable address


    On another server:

    root@www00 [/home/bettertv/www/bettercms]# sendmail -bv cindyambanta@iig-insurance.com
    cindyambanta@iig-insurance.com verified

    So no misspelling I think. I also took out /etc/eximmailtrap and restarted exim and I still get unroutable on that server. I set /var/cpanel/cpanel.config to have eximmailtrap=0 so it won't come back.

    Any ideas as to what else I can try?

    Thanks :)
     
  14. jrf

    jrf Well-Known Member

    Joined:
    Aug 19, 2003
    Messages:
    58
    Likes Received:
    0
    Trophy Points:
    6
    Just had the same type problem. Mail sent TO one of our address comes through but the Auto Responder returns an error, "no route to host" even though the domain is valid.

    Solution...

    deleted the /etc/eximmailtrap file
    changed /var/cpanel/cpanel.config to make eximmailtrap=0

    For now it is working.

    I am not having this problem on all servers, so it may be OS sensative.
     
    #14 jrf, Jun 2, 2006
    Last edited: Jun 2, 2006
  15. @home

    @home Well-Known Member

    Joined:
    Nov 5, 2003
    Messages:
    119
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Thanks

    Thanks guys!
     
Loading...

Share This Page