The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

unrouteable mail domain "any outside .com"

Discussion in 'E-mail Discussions' started by InternetPEI, Aug 11, 2006.

  1. InternetPEI

    InternetPEI Well-Known Member

    Joined:
    May 26, 2003
    Messages:
    102
    Likes Received:
    0
    Trophy Points:
    16
    I enabled PHPSuexec last night on the nobody sending mail issue, and now some of my scripts wont send mail, examples: image hosting site that emailed the links, and aplusbill to name a few.. Is there any fix to make these work again?

    This is an example error with one of the bounced emails from the image hosting script.

    Thanks for your help/suggestions.
    Jason

     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    You would need to check the exim_mainlog when you try and send an email. Also check if /etc/eximmaitrap exists and if it does, delete it. Then set eximmailtrap=0 in /var/cpanel/cpanel.config
     
  3. InternetPEI

    InternetPEI Well-Known Member

    Joined:
    May 26, 2003
    Messages:
    102
    Likes Received:
    0
    Trophy Points:
    16
    Hi,

    Still doing it :(

    I removed the eximmailtrap, removed the xmailer headers and also the cpanel.config was set to 0.

    When looking at the logs, it says the user nobody isnt allowed to send.


    (Since I disabled nobody in tweak settings)

    Is there anyway to get these scripts to allow mail to be sent?

    Current ones I know of that cant send from the server are phpBB2, my custom image hosting script, aplusbill..

    I can open up my email and can send fine, just since disabling nobody, server software cant send :(

    Any further suggestions?

    Thanks Jason
     
  4. sparek-3

    sparek-3 Well-Known Member

    Joined:
    Aug 10, 2002
    Messages:
    1,381
    Likes Received:
    23
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    If you disabled nobody sending, then you need to compile PHP as CGI, probably easiest with phpSuExec.
     
  5. mrskippy

    mrskippy Active Member

    Joined:
    Aug 11, 2006
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    I'm having the same problems, how do I do the compile?

    I have been having strange stuff like this happen all day. These problems weren't happen last night.
     
  6. dalem

    dalem Well-Known Member
    PartnerNOC

    Joined:
    Oct 24, 2003
    Messages:
    2,577
    Likes Received:
    40
    Trophy Points:
    48
    Location:
    SLC
    cPanel Access Level:
    DataCenter Provider
    recompile php with /scripts/easyapache or apache update in WHM and select phpsuexec
     
  7. mrskippy

    mrskippy Active Member

    Joined:
    Aug 11, 2006
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Yeah ... you know I'm having problems big time. My server can't even connect to anything off the server:

    [a fatal error or timeout occurred while processing this directive]There was an error while fetching http://layer1.cpanel.net/buildapache.rc
     
  8. InternetPEI

    InternetPEI Well-Known Member

    Joined:
    May 26, 2003
    Messages:
    102
    Likes Received:
    0
    Trophy Points:
    16
    Thanks sparek-3, that did the trick :)

    Mrskippy, do a reboot yet? Did you make any changes lately?
     
  9. mrskippy

    mrskippy Active Member

    Joined:
    Aug 11, 2006
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    The problem is my server won't connect to any server on the outside (same with e-mail, I can send mail to the server, but not from it). Basically, I can visit my server (Web sites, WHM, etc), but my server can't call out.
     
Loading...

Share This Page