The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

unrouteable mail domain "hotmail.com"

Discussion in 'E-mail Discussions' started by ramystyle, Dec 26, 2006.

  1. ramystyle

    ramystyle Well-Known Member

    Joined:
    Feb 9, 2004
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Montreal
    I don't understand why I suddently have this problem !
    I have searched the forum and I have the following UNCHECKED in Tweak Settings:

    Prevent the user "nobody" from sending out mail to remote addresses (PHP and CGI scripts generally run as nobody if you are not using PHPSuexec and Suexec respectively.)

    and I have the following set to ZERO

    The maximum each domain can send out per hour (0 is unlimited):

    My dns report shows no errors concerning mail...

    Can anyone help ?

    Thanks
     
  2. WebScHoLaR

    WebScHoLaR Well-Known Member

    Joined:
    Dec 14, 2005
    Messages:
    511
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Planet Earth
    Login to server via SSH and delete the file /etc/eximmailtrap if it exists. Secondly, edit the file /var/cpanel/cpanel.config and change eximmailtrap=1 to eximmailtrap=0.

    Restart the mailserver and there you go :)
     
  3. ramystyle

    ramystyle Well-Known Member

    Joined:
    Feb 9, 2004
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Montreal
    Hi WebScHoLaR !

    Thanks for the reply ! I did what you told me to do but still doesn't work :(
     
  4. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA
    run a dig hotmail.com in ssh. does the IP look local? check /etc/localdomains and make sure the damn box doesn't think hotmail is on your box. what's you resolv.conf have in it?
     
  5. dob3rman

    dob3rman Active Member

    Joined:
    Feb 13, 2005
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    Dig hotmail:

    ;; QUESTION SECTION:
    ;hotmail.com. IN A

    ;; ANSWER SECTION:
    hotmail.com. 3520 IN A 64.4.33.7
    hotmail.com. 3520 IN A 64.4.32.7

    ;; AUTHORITY SECTION:
    hotmail.com. 167729 IN NS ns2.msft.net.
    hotmail.com. 167729 IN NS ns3.msft.net.
    hotmail.com. 167729 IN NS ns4.msft.net.
    hotmail.com. 167729 IN NS ns5.msft.net.
    hotmail.com. 167729 IN NS ns1.msft.net.

    ;; ADDITIONAL SECTION:
    ns1.msft.net. 139987 IN A 207.68.160.190
    ns2.msft.net. 139987 IN A 65.54.240.126
    ns3.msft.net. 139987 IN A 213.199.144.151
    ns4.msft.net. 139987 IN A 207.46.66.126
    ns5.msft.net. 139987 IN A 65.55.238.126

    ;; Query time: 0 msec
    ;; SERVER: 64.15.129.239#53(64.15.129.239)
    ;; WHEN: Wed Dec 27 11:33:06 2006
    ;; MSG SIZE rcvd: 239

    Resolv.conf is good and hotmail is not in localdomains.


    Any clue ?
     
  6. ramystyle

    ramystyle Well-Known Member

    Joined:
    Feb 9, 2004
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Montreal
    btw this doesn't only happen with hotmail.. it's happening with gmail and many other email services..

    Any help would be appreciated !
     
  7. carlosferns2004

    carlosferns2004 Active Member

    Joined:
    May 5, 2005
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    india
    Hi

    Hello


    Disable this option
    Track the origin of messages sent though the mail server by adding the X-Source headers (exim 4.34+ required) from Tweak Settings and then try sending.




    Enjoy
    Regards
    Carlos
     
  8. codegirl42

    codegirl42 Well-Known Member

    Joined:
    Mar 9, 2006
    Messages:
    93
    Likes Received:
    0
    Trophy Points:
    6
    This fixed it for me. :) Thanks!
     
  9. ramystyle

    ramystyle Well-Known Member

    Joined:
    Feb 9, 2004
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Montreal
    Thanks !! It fixed it for us too :)
     
  10. erick_paper

    erick_paper Well-Known Member

    Joined:
    Apr 19, 2005
    Messages:
    245
    Likes Received:
    0
    Trophy Points:
    16
    Has this issue been resolved? What can I do? All the threads related to "PERM_FAILURE: SMTP Error (state 13)" come up with such discussions that seem to have been left un-resolved.

    All my email addresses are working fine. This is only happening with a new domain created in the last couple of days. Please help!

    TIA!
     
  11. ike

    ike Well-Known Member

    Joined:
    Apr 22, 2003
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6
    Ive had my server running fine for months without problem until yesterday i encountered this problem with all my domains. Ive read everything there is to read and changed everything suggested but it still hasnt fixed it. i might add no new users have been added or domains for that matter. its been ticking along nicely. now i cant send mail anywhere. Are there any other ideas?

    **************
    xxx@yahoo.com.au
    unrouteable mail domain "yahoo.com.au"


    resolv is fine, local domains are fine, i unchecked those things in tweak, i changed eximmailtrap to 0 and restarted exim. ive read 100 threads and nothing fixes it. i hate when things break when youre doing nothing. its easier to diagnose something if you were meddling with something, upgrading etc but for it to stop with all those things checked and set to 1 in the first place make me wonder why i would need to change them when they worked fine with the set before.


    any help would be greatly appreciated
     
  12. ike

    ike Well-Known Member

    Joined:
    Apr 22, 2003
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6
    /scripts/eximup --force

    fixed it for me. wierd.
     
Loading...

Share This Page