The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

unrouteable mail domain

Discussion in 'E-mail Discussions' started by lawrence.dcosta, Jul 5, 2006.

  1. lawrence.dcosta

    lawrence.dcosta Active Member

    Joined:
    Oct 6, 2005
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Hi

    Users of a particular domain hosted on the cpanel server are not able to send mails to a particular domain. The error message in logs says

    unrouteable mail domain "domainname.com"

    Has anyone come across such problem. Please suggest why it is occuring

    Lawrence
     
  2. innovative2001

    innovative2001 Active Member

    Joined:
    Jun 5, 2006
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    It is definitely a mail server problem; please forward such error e-mail message to your system administrator / hosting support. It has no relation with scripting.
     
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Well, unless the OP is the server admin. In that case, You really need to post the exim_mainlog transaction to determine the reason. BTW, is the domain being sent to hosted on the server, or off-server?
     
  4. bshelton@ole

    bshelton@ole Member

    Joined:
    Jul 7, 2004
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    I'm suddenly getting the same kind of error, this afternoon, accompanied by this...

    2006-07-06 13:56:20 1FxwU0-0004Th-LK failed to expand condition "${perl{checkspam}}" for lookuphost router: Gid 1006 is not permitted to relay mail at /etc/exim.pl line 365.

    2006-07-06 13:56:20 1FxwU0-0004Th-LK failed to expand condition "${perl{checkspam}}" for literal router: Gid 1006 is not permitted to relay mail at /etc/exim.pl line 365.

    2006-07-06 13:56:20 1FxwU0-0004Th-LK ** tkrebs@heidelhouse.com R=fail_remote_domains: unrouteable mail domain "heidelhouse.com"
     
  5. bshelton@ole

    bshelton@ole Member

    Joined:
    Jul 7, 2004
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1

    /etc/eximmailtrap seemed to be the culprit.

    WHat process/script creates that guy?
     
  6. mathew_p_a

    mathew_p_a Member

    Joined:
    Apr 8, 2005
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    unroutable domain

    You may need to check for the domainname in the localdomain file.
     
  7. nxds

    nxds Well-Known Member

    Joined:
    Jan 6, 2006
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    I think it gets created by setting true tweak settings -> Track the origin of messages sent though the mail server by adding the X-Source headers (exim 4.34+ required) in WHM
     
  8. muscleboy

    muscleboy Registered

    Joined:
    Jul 10, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    california
    the domain is not routeable

    That just means you are not allowing recursion on your DNS servers. Look in named.conf in your /etc directory. Under "options" you will probably see a recursion no; line. If you remove it save the file and reboot the DNS you will work again. Let me know if you have an actual server where you can edit named.conf and reboot DNS.

    If you do you need to do one more step to make your dns secure. But the above will get you going again as far as outside domains(domains not on your server)
    --Muscleboy
     
  9. Secret Agent

    Secret Agent Guest

    I have that problem also:

    My named.conf

    options {
    directory "/var/named";
    dump-file "/var/named/data/cache_dump.db";
    statistics-file "/var/named/data/named_stats.txt";
    version "private";
    allow-recursion { trusted; };
    allow-notify { trusted; };
    allow-transfer { trusted; };
     
Loading...

Share This Page