The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Unsupported PHP extensions crash cPanel?

Discussion in 'General Discussion' started by Chidori, Feb 29, 2008.

  1. Chidori

    Chidori Registered

    Joined:
    Oct 8, 2006
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Scottsdale, Arizona
    Hi,

    I have been told that if I try to install a PHP extension manually (in this case APC), it may crash cPanel/WHM. Is there any truths to these claims, or can I safely install the extension on my server?

    Thanks in advance!
     
  2. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    If the installation is done improperly, you could have a non-functional PHP installation. However, it is unlikely that you would crash cPanel/WHM itself. Remember cPanel/WHM is served by cpsrvd, not Apache. Therefore even if Apache goes down, cPanel/WHM will remain functional.
     
Loading...

Share This Page