Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Unsupported protocol error ERR_SSL_VERSION_OR_CIPHER_MISMATCH

Discussion in 'Security' started by PPNSteve, Aug 22, 2017.

  1. PPNSteve

    PPNSteve Well-Known Member

    Joined:
    Mar 13, 2003
    Messages:
    404
    Likes Received:
    2
    Trophy Points:
    168
    Location:
    Somewhere in Ilex Forest
    cPanel Access Level:
    Root Administrator
    Twitter:
    On a server with other working ssl sites, i added one site to the autoSSL and it gen'ed a comodo cert but when visiting the site we get ..unsupported protocol. ERR_SSL_VERSION_OR_CIPHER_MISMATCH using the cPanel generated SSL cert in chrome (and win10's edge browser won't load it either). URL in question: [Removed URL]

    why?

    how do we fix it??
     
  2. PPNSteve

    PPNSteve Well-Known Member

    Joined:
    Mar 13, 2003
    Messages:
    404
    Likes Received:
    2
    Trophy Points:
    168
    Location:
    Somewhere in Ilex Forest
    cPanel Access Level:
    Root Administrator
    Twitter:
    never mind.. I edited the avail ciphers and restarted apache.. that seemed to be all it needed.
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    40,627
    Likes Received:
    1,550
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    I'm happy to see you were able to solve the issue. Thank you for updating us with the outcome.
     
  4. Kent Brockman

    Kent Brockman Well-Known Member

    Joined:
    Jan 20, 2008
    Messages:
    1,171
    Likes Received:
    5
    Trophy Points:
    68
    Location:
    Buenos Aires, Argentina
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello! I'm having the same issue. How does your cipher list look like after that change?
     
  5. urgido

    urgido Well-Known Member

    Joined:
    Jul 19, 2005
    Messages:
    91
    Likes Received:
    4
    Trophy Points:
    158
    cPanel Access Level:
    Root Administrator
    Same issue
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    40,627
    Likes Received:
    1,550
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Are you using any custom "SSL Cipher Suite" or "SSL/TLS Protocols" values in "WHM >> Apache Configuration >> Global Configuration"?

    Thank you.
     
  7. urgido

    urgido Well-Known Member

    Joined:
    Jul 19, 2005
    Messages:
    91
    Likes Received:
    4
    Trophy Points:
    158
    cPanel Access Level:
    Root Administrator
    Both are custom

     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    40,627
    Likes Received:
    1,550
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Are you using custom entries for a specific purpose? If not, can you try reverting to the default values to see if the issue persists?

    Thank you.
     
  9. urgido

    urgido Well-Known Member

    Joined:
    Jul 19, 2005
    Messages:
    91
    Likes Received:
    4
    Trophy Points:
    158
    cPanel Access Level:
    Root Administrator
    I am using this values for security purpose but I have the same values on other three servers and it's the first time that this happens.

    Today, I installed a SSL cert for one domain (RapidSSL).
    I have many other sites with intalled certs with no issues on this same server. The custom entries had more than 10 months ago on my apache conf.

    Do I need to revert these values?
     
  10. urgido

    urgido Well-Known Member

    Joined:
    Jul 19, 2005
    Messages:
    91
    Likes Received:
    4
    Trophy Points:
    158
    cPanel Access Level:
    Root Administrator
    http:// -> Works perfectly
    https:// -> ERR_SSL_VERSION_OR_CIPHER_MISMATCH
     
  11. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    40,627
    Likes Received:
    1,550
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Feel free to open a support ticket using the link in my signature if you'd like us to take a closer look to see if we can find any details on what could be causing that error message.

    Thank you.
     
  12. urgido

    urgido Well-Known Member

    Joined:
    Jul 19, 2005
    Messages:
    91
    Likes Received:
    4
    Trophy Points:
    158
    cPanel Access Level:
    Root Administrator
    The ticket was opened yesterday. ID 9012325

    Regards
     
    #12 urgido, Nov 8, 2017
    Last edited by a moderator: Nov 8, 2017
  13. urgido

    urgido Well-Known Member

    Joined:
    Jul 19, 2005
    Messages:
    91
    Likes Received:
    4
    Trophy Points:
    158
    cPanel Access Level:
    Root Administrator
    Solution: Problem with DNS zone, exactly with NS values.

    I invite to all who has similar issue looks into their DNS values finding something strange or wrong.



    Regards
     
    cPanelMichael likes this.
  14. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    40,627
    Likes Received:
    1,550
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    I'm glad to see the issue was sorted. Thank you for updating us with the outcome.
     
Loading...

Share This Page