The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Unusual Error in email for FTPPUT

Discussion in 'E-mail Discussions' started by bmak, Jun 11, 2004.

  1. bmak

    bmak Registered

    Joined:
    May 24, 2004
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    Just discoved this while trying to make a backup of an account through the users's cpanel. While using the ftp as the storage method, i get this after the backup & archive are complete:


    Can't call method "login" on an undefined value at /usr/local/cpanel/bin/ftpput line 24.
    --------------------------------------------------------
    Copying Reseller Config...Done
    Copying Mail files....Done
    Copying proftpd file....Done
    Copying www logs.............
    .........
    Done
    Grabbing mysql dbs...Done
    Grabbing mysql privs...Done
    Copying mailman lists....Done
    Copying mailman archives....Done
    Copying homedir....Done
    Copying cpuser file.......Done
    Copying crontab file.......Done
    Copying quota info.......Done
    Storing Subdomains....
    Done
    Storing Parked Domains....
    Done
    Storing Addon Domains....
    Done
    Copying password.......Done
    Copying shell.......Done
    pkgacctfile is: /tmp/backup-6.11.2004_19-30-08_???.tar.gz
    Creating Archive ....Done
    md5sum is: 64c236a95c302c0c1c39a9b4db663263
    --------------------------------------------------------

    Is this a script error or what am i doing wrong?
     
  2. DWHS.net

    DWHS.net Well-Known Member
    PartnerNOC

    Joined:
    Jul 28, 2002
    Messages:
    1,569
    Likes Received:
    6
    Trophy Points:
    38
    Location:
    LA, Costa RIca
    cPanel Access Level:
    Root Administrator
    Any news on this I got the same error today but it seems to work o.k. despite the error.

    I havn't tried a restore though.
     
  3. forumwurm

    forumwurm Member

    Joined:
    Aug 10, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    exactly the same error, me too.

    i've tryed ftp and passiv ftp with and without password.

    everytime the same error :(
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Sounds like a missing subroutine in the cpanel perl script. I'd suggest logging it in bugzilla.
     
  5. fernandomariani

    fernandomariani Registered

    Joined:
    Jul 31, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    I got the same problem today
    anyone know how to solve it?
    thanks
     
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    If noone has logged it, then you're going to be waiting a long time for a fix ;)
     
Loading...

Share This Page