jive

Registered
Jan 11, 2004
3
0
151
I don't need proftpd, so I removed it. I edited chkservd.d to
remove the proftpd entry. Now, the daily upcp script has kindly reintalled proftpd for me :mad:

How do I stop upcp from doing this - couldn't find out how by looking at the script.
 

ciphervendor

Well-Known Member
Aug 26, 2002
1,052
0
166
Uncheck FTP in the service manager section of WHM. cPanel may install ProFTP on the first night, but it won't attempt to start it. If it does, submit a bug report.
 

jive

Registered
Jan 11, 2004
3
0
151
The Proftpd check box in the service manager doesn't work - there's another report of it one of these threads. I removed the chkservd.d entry for Proftpd, but the upcp script keeps installing proftpd and when I do a status check it's running again.
 

ciphervendor

Well-Known Member
Aug 26, 2002
1,052
0
166
Your best bet is to submit a bug report.
 

jb605

Member
Dec 5, 2003
14
0
151
I know this is an old thread. But I am still experiencing the same problem after one year. Why does cpanel insists on installing proftpd for me?

I also tried webhost manager to uncheck proftpd, tried rpm -e, tried remove from chkserv.d, tried chkconfig --del, but this ghost proftpd is coming back every night and running as user NOBODY!
 

BenThomas

Well-Known Member
Feb 12, 2004
598
0
166
Houston, Texas USA
cPanel Access Level
Root Administrator
Proftpd is restarted automatically as part of the installation process. It will be automatically installed if it is not installed on your system. Disabling the ftp servers in the "Service Manager" and leaving it installed should keep it from ever running again. When a service is disable the following file is created:

/etc/<servicename>disable

In the case of proftpd/pureftpd, the following files will be created in /etc:

ftpddisable
proftpddisable
pureftpddisable
pure-ftpddisable

These all correspond to the various releases of chkservd, and currently the most important one is /etc/ftpddisable.

HTH
 

jb605

Member
Dec 5, 2003
14
0
151
Thanks for your information. According to one of you technician, just disable it won't prevent it from being reinstalled. Here is the advice I got from technical support:

I believe you would need to set "cPanel Package Updates" to "Never Update" under "Update Config" in WHM if you don't wish this to be reinstalled. Un-checking it under "Service Manager" only prevents chkservd from monitoring it. Alternatively (and unsupported), you could modify /scripts/ftpup such that it doesn't install an FTP server, and chattr +i it.
I am very surprised to see that cpanel is designed in such a way that I can only disable cpanel update to prevent proftpd from being re-installed, even if I tell cpanel to disable proftpd.

Can you clarify whether this is true or not?

Thanks.
 

anup123

Well-Known Member
Mar 29, 2004
890
1
168
This Planet
There are many things which cpanel does which the admins would not want and it does not do what the admins would want...

Imagine a customer who does not need anything but mail accounts ... no hosting/no ftp... just mail accounts. is there a way this can be done? Put in as a feature request and i am sure it would never ever reach anywhere on the priority list. Forget about the Feature Request, even bugs fixing gets a cold shoulder response :/

Anup
 

BenThomas

Well-Known Member
Feb 12, 2004
598
0
166
Houston, Texas USA
cPanel Access Level
Root Administrator
As I previously stated:

Disabling the ftp servers in the "Service Manager" and leaving it installed should keep it from ever running again.

It's restarted as part of the re-installation process after you remove it. So if it is still there, then it won't be reinstalled and restarted.