The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

upcp breaks exim every night

Discussion in 'General Discussion' started by neraath, Sep 1, 2004.

  1. neraath

    neraath Member

    May 25, 2004
    Likes Received:
    Trophy Points:
    Aggieland, TX
    Every night for the past few nights, the upcp script has run and from what I can tell it is rebuilding exim over and over and over again. Every night, it also coincides with the rebuild of openssl. However, when the openssl finishes rebuilding, it fails to install because it automatically detects that it is installed already. This in return fails the exim build, and my exim server dies every night at 3 AM. So, I also don't know that the server is dead till I check my email and find that the upcp script is not in my inbox.

    What I've done to fix this every day is do run 'make deinstall' in the openssl port directory, then copy over 2 library files to /usr/lib and running 'make install' in the exim directory. This fixes it, and I restart exim from the WHM link. But, I cannot do this every day and need to know how to fix this so it stops again.

    One weird thing is that I can run /scripts/upcp multiple times after I fix the install, but can't figure out what script is saying I need to rebuild exim.

    System Info:
    FreeBSD 4.9-Stable
    WHM 9.7.2 cPanel 9.7.7-R9

    Please, any advise would be appreciated!!!
  2. easyhoster1

    easyhoster1 Well-Known Member

    Sep 25, 2003
    Likes Received:
    Trophy Points:

Share This Page