The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

upcp <defunct> issue...

Discussion in 'General Discussion' started by irchs, Mar 8, 2005.

  1. irchs

    irchs Well-Known Member

    Joined:
    Jun 3, 2004
    Messages:
    76
    Likes Received:
    0
    Trophy Points:
    6
    Everytime I run upcp via a cron, it becomes defunct and is in my process list eternally, if I then run upcp manually via ssh, the defunct upcp finishes normally and so does my manual one. upcp works fine manually at all times.

    This is x86_64, current 43.

    Anyone with any ideas?!

    Thanks

    Jan
     
  2. demomen

    demomen Well-Known Member

    Joined:
    Sep 25, 2004
    Messages:
    111
    Likes Received:
    0
    Trophy Points:
    16
    Have the same problem,

    Any ideas:


    24613 root 9 0 0 0 0 Z 0.0 0.0 0:00 0 upcp <defunct>
     
  3. chae

    chae Well-Known Member

    Joined:
    Apr 19, 2003
    Messages:
    145
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Auckland, New Zealand
    On our server we see the upcp <defunct> show up after a major or fairly large sized update. It always seems to hang just at the point where upcp does the automatic email. Kill the CROND (not cron) process and everything is all well. Upcp will run normally for days & weeks then comes along another large update of cPanel/WHM and we see upcp (defunct) the following morning.

    Strange
     
  4. irchs

    irchs Well-Known Member

    Joined:
    Jun 3, 2004
    Messages:
    76
    Likes Received:
    0
    Trophy Points:
    6
    This issue is still happening, I have noticed in upcp also, that the current version for x86_64 is 10.0.0-CURRENT_43 (as stated here: http://layer2.cpanel.net/) but in my upcp cron job log it shows upcp doing this:
    It then goes ahead and tries to sync.

    Hope this provides some clues...

    Jan
     
  5. isputra

    isputra Well-Known Member

    Joined:
    May 3, 2003
    Messages:
    576
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Mbelitar
    Is there any solution for this problem ?

    When i use top, i also get defunct on upcp and exim
     
  6. isputra

    isputra Well-Known Member

    Joined:
    May 3, 2003
    Messages:
    576
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Mbelitar
    OK, after reading on chae suggestion to kill CROND, defunct will be gone and upcp back to normal.
     
Loading...

Share This Page