upcp failure - migrate_local_ini_to_php_ini

aligonen

Member
Jan 24, 2012
5
0
51
cPanel Access Level
Root Administrator
My update problem, please help me

cPanel & WHM update failure in upcp script ?


Log report is :
[2017-11-20 21:35:29 +0300] E [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini] The “/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini” command (process 10304) reported error number 255 when it ended.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,254
463
Hello,

Could you run the command below and let us know the output?

Code:
/scripts/migrate_local_ini_to_php_ini --run --verbose
Thank you.
 
Last edited:

aligonen

Member
Jan 24, 2012
5
0
51
cPanel Access Level
Root Administrator
Migrate each installed PHP’s …/etc/php.d/local.ini to …/etc/php.ini.

This is needed because EasyAapache 4 no longer utilizes local.ini file.

Options:
--help this screen
--run perform the migration
--verbose Enable verbose output

Thank you
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,254
463
Hello,

I apologize, here's the full command you need to run:

Code:
/scripts/migrate_local_ini_to_php_ini --run --verbose
Thank you.
 

aligonen

Member
Jan 24, 2012
5
0
51
cPanel Access Level
Root Administrator
Processing ea-php54 …
No local.ini.
… done!
Processing ea-php55 …
No local.ini.
… done!
Processing ea-php56 …
No local.ini.
… done!
Processing ea-php70 …
No local.ini.
… done!
Processing ea-php71 …
Cpanel::Exception::FeatureNotEnabled/(XID mvmdpc) The “ea-php71” package does not provide an executable binary.
at /usr/local/cpanel/Cpanel/Exception/CORE.pm line 336.
Cpanel::Exception::create("FeatureNotEnabled", "The \x{e2}\x{80}\x{9c}[_1]\x{e2}\x{80}\x{9d} package does not provide an executable binary.", ARRAY(0x23dae58)) called at /usr/local/cpanel/Cpanel/Exception.pm line 46
Cpanel::Exception::__ANON__(__CPANEL_HIDDEN__, __CPANEL_HIDDEN__, ARRAY(0x23dae58)) called at /usr/local/cpanel/Cpanel/ProgLang/Supported/php.pm line 318
Cpanel::ProgLang::Supported::php::get_package(Cpanel::ProgLang::Supported::php=HASH(0x23db668), "package", "ea-php71") called at /usr/local/cpanel/Cpanel/ProgLang/Supported/php/Ini.pm line 233
Cpanel::ProgLang::Supported::php::Ini::new("Cpanel::ProgLang::Supported::php::Ini", "lang", Cpanel::ProgLang::Supported::php=HASH(0x23db668), "package", "ea-php71") called at /usr/local/cpanel/Cpanel/ProgLang/Supported/php.pm line 369
Cpanel::ProgLang::Supported::php::get_ini(Cpanel::ProgLang::Supported::php=HASH(0x23db668), "package", "ea-php71") called at /scripts/migrate_local_ini_to_php_ini line 44
scripts::migrate_local_ini_to_php_ini::run("--run", "--verbose") called at /scripts/migrate_local_ini_to_php_ini line 27
[[email protected] ~]#
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,254
463
Cpanel::Exception::FeatureNotEnabled/(XID mvmdpc) The “ea-php71” package does not provide an executable binary.
It looks like this is due to an incomplete PHP 7.1 installation. Could you run the command below and let us know the output?

Code:
rpm -qa|grep php71
Thank you.
 

aligonen

Member
Jan 24, 2012
5
0
51
cPanel Access Level
Root Administrator
ea-php71-runtime-7.1.11-1.1.1.cpanel.x86_64
ea-php71-php-common-7.1.11-1.1.3.cpanel.x86_64
ea-php71-php-zip-7.1.11-1.1.3.cpanel.x86_64
ea-php71-php-mbstring-7.1.11-1.1.3.cpanel.x86_64
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,254
463
Hello,

You will need to remove those RPMs with the following commands:

Code:
rpm -e --nodeps ea-php71-runtime-7.1.11-1.1.1.cpanel.x86_64
rpm -e --nodeps ea-php71-php-common-7.1.11-1.1.3.cpanel.x86_64
rpm -e --nodeps ea-php71-php-zip-7.1.11-1.1.3.cpanel.x86_64
rpm -e --nodeps ea-php71-php-mbstring-7.1.11-1.1.3.cpanel.x86_64
Or, if you want to install PHP 7.1, run the following command:

Code:
yum install ea-php71
Thank you.