LegionOfBrad

Registered
Apr 27, 2010
1
0
51
Hi there, i'm trying to update my Cpanel/WHM but right now when i do /scripts/upcp - force i get this error
Code:
Can't locate Cpanel/CPAN/URI/Escape.pm in @INC (@INC contains: /scripts /usr/lib/perl5/5.8.8/i686-linux /usr/lib/perl5/5.8.8 /usr/lib/perl5/site_perl/5.8.8/i686-linux /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7/i686-linux /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl/5.6.2 /usr/lib/perl5/site_perl .) at /scripts/cPScript/Encoder/URI.pm line 8.
BEGIN failed--compilation aborted at /scripts/cPScript/Encoder/URI.pm line 8.
Compilation failed in require at /scripts/cPScript/HttpRequest.pm line 15.
BEGIN failed--compilation aborted at /scripts/cPScript/HttpRequest.pm line 15.
Compilation failed in require at /scripts/upcp line 17.
BEGIN failed--compilation aborted at /scripts/upcp line 17.
Does anyone have any ideas?

Perl version is 5.8.8. When i try to reinstall that i get:-

Code:
[email protected] [/usr/local/src]# cd perl588installer
[email protected] [/usr/local/src/perl588installer]# ./install
Unable to retrieve Perl source at ./install line 39.
Right now i'm at a loss and going round in circles :(
 

Kevinfrom

Well-Known Member
Jan 18, 2008
47
1
56
Please open a support request and we will gladly take a look at it for you.

Would need to see several things on this server like perl setup, missing modules, update system, etc..