The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

upcp --force fails due to mysql 4.1.19

Discussion in 'General Discussion' started by oulzac, Jun 1, 2006.

  1. oulzac

    oulzac Well-Known Member

    Joined:
    Aug 7, 2005
    Messages:
    131
    Likes Received:
    0
    Trophy Points:
    16
    I am trying to update cpanel/whm so I can fix my easyapache issues so I can compile apache/php correctly, but in order to do that I need to update, and since I have already updated mysql 4.1.19, it wont, here is what it shows, and then hangs for hours:

    root@ [~]# /scripts/upcp --force
    Updating /scripts ...
    Sync Source: http://httpupdate.cpanel.net/RELEASE/scripts
    Fetching http://httpupdate.cpanel.net/cpanelsync/RELEASE/scripts/.cpanelsync.lock (0)....@198.66.78.11......connected......receiving...100%......Done
    Fetching http://httpupdate.cpanel.net/cpanelsync/RELEASE/scripts/.cpanelsync.bz2 (0)....@198.66.78.11......connected......receiving...31%...62%...93%...100%......Done
    Done updating /scripts
    Found hostname to be athena.liveshere.com, which resolves to 69.22.169.142
    Hostname Virtual Host is already setup
    PHP version file has been updated to 4.4.2
    Ftp Quota Check v1.0
    Updating bettydis:dropbox....Done
    Updating hosting:mhartman....Done
    Updating jadw:fran....Done
    Updating sat422:ftp....Done
    [userdomains] user alaskad2: missing DNS= line in /var/cpanel/users/alaskad2 at /scripts/updateuserdomains line 206.
    [userdomains] user alaskad3: missing DNS= line in /var/cpanel/users/alaskad3 at /scripts/updateuserdomains line 206.
    [userdomains] user alaskado: missing DNS= line in /var/cpanel/users/alaskado at /scripts/updateuserdomains line 206.
    [userdomains] user arfies: missing DNS= line in /var/cpanel/users/arfies at /scripts/updateuserdomains line 206.
    [userdomains] user lifealas: missing DNS= line in /var/cpanel/users/lifealas at /scripts/updateuserdomains line 206.
    [userdomains] user queercal: missing DNS= line in /var/cpanel/users/queercal at /scripts/updateuserdomains line 206.
    [userdomains] user quinnat: missing DNS= line in /var/cpanel/users/quinnat at /scripts/updateuserdomains line 206.
    [userdomains] user quinnatl: missing DNS= line in /var/cpanel/users/quinnatl at /scripts/updateuserdomains line 206.
    [userdomains] user adradmin: missing DNS= line in /var/cpanel/users/adradmin at /scripts/updateuserdomains line 206.
    Doing a manual update...
    Cpanel updates are coming from layer2.cpanel.net
    Using smartcheck config 5.32 for smartctl(5.33)
    Checking /dev/hda....Ok
    Checking /dev/hdb....Ok
    Ftp Setup Script Version 6.0
    Fetching version information from http://updates.cpanel.net/ftpinstall/version (RELEASE)....Fetching http://updates.cpanel.net/ftpinstall/version (0)....@198.66.78.12......connected......receiving...100%......Done
    Done
    This is the pure-ftpd 1.0.20 installer release number 17.tls for platform fedora 3
    pure-ftpd is up to date. Use ftpup --force to force a reinstall
    Exim Setup Script Version 20.0
    Fetching version information from http://updates.cpanel.net/eximinstall/version (RELEASE)....Fetching http://updates.cpanel.net/eximinstall/version (0)....@198.66.78.12......connected......receiving...100%......Done
    Done
    This is the exim 4.52 installer release number 7 for platform fedora 3
    exim is up to date. Use eximup --force to force a reinstall
    MySQL Setup Script Version 7.0
    Fetching http://httpupdate.cpanel.net/mysqlinstall/RELEASE/cPpkgversion (0)....@198.66.78.11......connected......receiving...61%...100%......Done
    Loaded cPPkgs::MySQL ok!
    This is the cPPkgs::MySQL 4.1.19 installer for Linux.
    MySQL 4.1.19 is up to date

    I know how to fix the userdomains errors, but that should not effect the update in anyway.
    why is it hanging at the mysql section, when there isnt anything to update?
    anyone have any ideas on this one?
     
  2. oulzac

    oulzac Well-Known Member

    Joined:
    Aug 7, 2005
    Messages:
    131
    Likes Received:
    0
    Trophy Points:
    16
    nevermind, found the problem.

    if anyone has this problem, its more than likely due to a high load caused by mysql not being installed correctly, after shutting down the update, I notice the server load was over 200 :eek:
    I then re updated mysql and then upcp worked just fine.
     
  3. Ivanner

    Ivanner Active Member

    Joined:
    Oct 13, 2003
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    1
    It actually doesn't hang, but if you have several files in your server, then the command setfiles takes long to execute.
    You can trace the setfiles command from WHM.
    Just give it some time and it will finish.
     
Loading...

Share This Page