The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

upcp hangs on update courier

Discussion in 'General Discussion' started by Danny_T, Jun 10, 2007.

  1. Danny_T

    Danny_T Well-Known Member

    Joined:
    Jul 19, 2005
    Messages:
    181
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Netherlands
    Hi there,

    WHM 11.1.0 cPanel 11.4.0-C13355
    FEDORA 3 i686 - WHM X v3.1.0

    5 days ago was a last upcp update. After investigate i do see this :

    /scripts/upcp hangs on:

    Code:
    warning: waiting for transaction lock
    while the update for courier is running.
    I have to kill upcp processes.

    So i ran this:

    Code:
    # ./courierup
    courier-imap Setup Script Version 1.0
    Fetching version information from http://updates.cpanel.net/courierinstall/version (CURRENT)....Fetching http://updates.cpanel.net/courierinstall/version (0)....@69.90.250.35......connected......receiving...100%......Done
    Done
    This is the courier-authlib 0.59.2 installer release number 1cp
    courier-authlib is out of date (courier-authlib-0.57-6cp != courier-authlib-0.59.2-1cp)
    courier-authlib-pipe is out of date (courier-authlib-pipe-0.57-6cp != courier-authlib-pipe-0.59.2-1cp)
    courier-authlib-devel is out of date (courier-authlib-devel-0.57-6cp != courier-authlib-devel-0.59.2-1cp)
    Using newyum support...
    warning: waiting for transaction lock
    And it waits and doing nothing.

    So i started to download manual the rpm's and did:

    Code:
    # rpm -Uvh courier-authlib-0.59.2-1cp.i386.rpm courier-authlib-devel-0.59.2-1cp.i386.rpm courier-authlib-pipe-0.59.2-1cp.i386.rpm courier-authlib-userdb-0.59.2-1cp.i386.rpm
    error: Failed dependencies:
            /usr/local/bin/perl is needed by courier-authlib-userdb-0.59.2-1cp.i386
    
    # ls -l /usr/local/bin/perl                                 lrwxrwxrwx  1 root root 13 Oct 11  2006 /usr/local/bin/perl -> /usr/bin/perl*
    
    # /usr/local/bin/perl --version                             
    This is perl, v5.8.7 built for i686-linux
    Whats going on and how to fix?
     
  2. rachweb

    rachweb Well-Known Member

    Joined:
    Jun 26, 2004
    Messages:
    268
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    amsterdam
    Fedora core 3 is not supported any more by Cpanel and also bij Fedora. Upgrade your Fedora to 5. Fedora 6 has some problems. Or change the OS to Centos 4/5.

    Fedora isn't recommend because the limited support and is a development OS.
     
  3. Danny_T

    Danny_T Well-Known Member

    Joined:
    Jul 19, 2005
    Messages:
    181
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Netherlands
    It is still supported. I see CPANEL FC3 packages and no warnings in WHM that the OS is outdated and not supported anymore.
    Besides, i dont want to upgrade my hosting system. I just do not know what will be happen during and after the upgrade. As i have doing OS upgrades in VMWare test environments and a lot did failed.

    And the best part, why upgrade if the system works fine. This above issue is a cpanel problem and has to be resolved :)

    Until i do not see any warnings in WHM about outdated/unsupported OS, it must be supported.

    Danny.
     
  4. rachweb

    rachweb Well-Known Member

    Joined:
    Jun 26, 2004
    Messages:
    268
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    amsterdam
    Fedora core 3 isnt supported by Fedora. Look at http://www.cpanel.net/products/cPanelandWHM/linux/sys_requirements.htm

    Operating Systems at EOL

    These operating systems are supported by cPanel but no longer receive updates from the vendor. cPanel recommend upgrading to a vendor supported distribution. New installations on these OSes are not supported.
    Fedora FedoraTM Cores 1, 2, 3, 4
    RedHat Fedora-Legacy (Red Hat®) 7.3, 9
     
Loading...

Share This Page