Upcp: pre scriptlet failed errors

FvdM

Member
Feb 7, 2004
9
0
151
Every night /scripts/upcp runs on my CentOS 4.3 server.

When it starts with yum I get 'install: %pre scriptlet failed' failed errors on all packages it tries to install. At the and it says that they are all installed/updated which is not the case because the next night I get the same results!

Running 'yum -y update' in SSH returns the same errors.

Here is the newyum part from the upcp email:

Using newyum support...
error: install: %pre scriptlet failed (2), skipping pam-0.77-66.14
error: install: %pre scriptlet failed (2), skipping openssh-server-3.9p1-8.RHEL4.12
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package openssh-server.i386 0:3.9p1-8.RHEL4.12 set to be updated
--> Running transaction check
--> Processing Dependency: libpam.so.0 for package: openssh-server
--> Processing Dependency: /etc/pam.d/system-auth for package: openssh-server
--> Processing Dependency: /lib/security/pam_loginuid.so for package: openssh-server
Importing Additional filelist information for dependency resolution
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package pam.i386 0:0.77-66.14 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
Package Arch Version Repository Size
=============================================================================
Updating:
openssh-server i386 3.9p1-8.RHEL4.12 base 207 k
Installing for dependencies:
pam i386 0.77-66.14 base 1.8 M

Transaction Summary
=============================================================================
Install 1 Package(s)
Update 1 Package(s)
Remove 0 Package(s)
Total download size: 2.0 M
Downloading Packages:
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction

Dependency Installed: pam.i386 0:0.77-66.14
Updated: openssh-server.i386 0:3.9p1-8.RHEL4.12
Complete!
error: install: %pre scriptlet failed (2), skipping pam-0.77-66.14
error: install: %pre scriptlet failed (2), skipping hal-0.4.2-3.EL4
error: install: %pre scriptlet failed (2), skipping nscd-2.3.4-2.19
error: install: %pre scriptlet failed (2), skipping diskdumputils-1.2.8-2
error: install: %pre scriptlet failed (2), skipping openssh-server-3.9p1-8.RHEL4.12
error: install: %pre scriptlet failed (2), skipping initscripts-7.93.24.EL-1.1.centos4
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package nscd.i386 0:2.3.4-2.19 set to be updated
---> Package initscripts.i386 0:7.93.24.EL-1.1.centos4 set to be updated
---> Package diskdumputils.i386 0:1.2.8-2 set to be updated
---> Package openssh-server.i386 0:3.9p1-8.RHEL4.12 set to be updated
---> Package hal.i386 0:0.4.2-3.EL4 set to be updated
--> Running transaction check
--> Processing Dependency: libpam.so.0 for package: openssh-server
--> Processing Dependency: /etc/pam.d/system-auth for package: openssh-server
--> Processing Dependency: /lib/security/pam_loginuid.so for package: openssh-server
Importing Additional filelist information for dependency resolution
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package pam.i386 0:0.77-66.14 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
Package Arch Version Repository Size
=============================================================================
Updating:
diskdumputils i386 1.2.8-2 base 54 k
hal i386 0.4.2-3.EL4 base 152 k
initscripts i386 7.93.24.EL-1.1.centos4 base 1.1 M
nscd i386 2.3.4-2.19 base 125 k
openssh-server i386 3.9p1-8.RHEL4.12 base 207 k
Installing for dependencies:
pam i386 0.77-66.14 base 1.8 M

Transaction Summary
=============================================================================
Install 1 Package(s)
Update 5 Package(s)
Remove 0 Package(s)
Total download size: 3.5 M
Downloading Packages:
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction

Dependency Installed: pam.i386 0:0.77-66.14
Updated: diskdumputils.i386 0:1.2.8-2 hal.i386 0:0.4.2-3.EL4 initscripts.i386 0:7.93.24.EL-1.1.centos4 nscd.i386 0:2.3.4-2.19 openssh-server.i386 0:3.9p1-8.RHEL4.12
Complete!
Does someone know what is causing this and/or knows how to get this to function normally?
 

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,466
31
473
Go on, have a guess
Since it's a problem with yum on CentOS you might be better of checking on their forums. Do make sure that you've reset any changes in your yum configuration to the CentOS v4 defaults incase any modification has broken something.