The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

upcp - S.M.A.R.T not enabled

Discussion in 'General Discussion' started by ljesh, Dec 16, 2008.

  1. ljesh

    ljesh Well-Known Member

    Joined:
    Aug 2, 2008
    Messages:
    65
    Likes Received:
    0
    Trophy Points:
    6
    Hello.
    Every night /scripts/upcp runs and I get e-mail. I am worried about this part:
    Checking /dev/sda....S.M.A.R.T does not appear to be enabled for this device.
    Checking /dev/sdb....S.M.A.R.T does not appear to be enabled for this device.

    How do I enable S.M.A.R.T. (should I?) permanently?

    I hope to get detailed info from someone that would like to help.
    Thanks :)
     
  2. arunsv84

    arunsv84 Well-Known Member

    Joined:
    Oct 20, 2008
    Messages:
    373
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    127.0.0.1
    cPanel Access Level:
    Root Administrator
  3. ljesh

    ljesh Well-Known Member

    Joined:
    Aug 2, 2008
    Messages:
    65
    Likes Received:
    0
    Trophy Points:
    6
    None of those two links helped my issue.
    By the way, I am running CentOS 5.2
     
  4. sebby

    sebby Well-Known Member

    Joined:
    Jun 15, 2004
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
    Hi ljesh:

    If your hard drives are SMART compatible (Self-Monitoring, Analysis, and Reporting Technology) you should activate SMART through the BIOS (ask a sysadmin in your datacenter to do it). SMART can be very useful as it will notify you in advance when the storage devices are about to die (an hourly Logcheck will allow you to react promptly). Be aware that you will also get some false alarms as well.

    Cheers,

    Sebby
     
  5. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,456
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Do you have SATA drives on your server?
     
  6. ljesh

    ljesh Well-Known Member

    Joined:
    Aug 2, 2008
    Messages:
    65
    Likes Received:
    0
    Trophy Points:
    6
    Hi Sebby,
    I know how important is to enable SMART, that is why I am trying to enable it :)
    SMART is enabled in BIOS.
    Yes, two WD2500JS-55N.

    Still this issue is happening. upcp informing me that smart is not enabled...
    Though, running
    gives this as result
     
  7. yashraj

    yashraj Member

    Joined:
    Nov 16, 2008
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    United states
    try:
    smartctl -d scsi --smart=on --offlineauto=on --saveauto=on /dev/sda
     
  8. ljesh

    ljesh Well-Known Member

    Joined:
    Aug 2, 2008
    Messages:
    65
    Likes Received:
    0
    Trophy Points:
    6
    No, it doesn't work

     
  9. Nathan D.

    Nathan D. Well-Known Member

    Joined:
    Mar 21, 2004
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Virginia
    I have the same issue as well and I've tried all steps in this thread but no luck. Identical errors as the initiator of this thread.
     
  10. rs-freddo

    rs-freddo Well-Known Member

    Joined:
    May 13, 2003
    Messages:
    832
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Australia
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page