The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

UPCP showing errors

Discussion in 'General Discussion' started by ranish, Jul 22, 2004.

  1. ranish

    ranish Member

    Joined:
    Oct 4, 2003
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    India
    Hello,

    While running any scripts such as upcp, sysup,rpmup etc we are getting the following error
    =============
    /scripts/upcp
    PHP version file is up to date
    Doing a manual update...
    Cpanel updates are coming from layer2.cpanel.net
    passwd: Unknown user name 'xfs'.
    Locking password for user daemon.
    passwd: Success
    Checking /dev/hda....OK
    Checking /dev/hdc....OK
    x - creating lock directory
    x - SKIPPING /usr/local/lib/php.ini (file already exists)
    Using Mysql4
    Using RPM Backend: RPM version 4.2
    Fetching rpm updates list...Done

    gzip: /root/.cpupdates/7-23-2004.updates.gz: unexpected end of file
    Cannot fetch rpm updates list at /scripts/cPanelRPM.pm line 154.
    Using RPM Backend: RPM version 4.2
    Fetching rpm updates list...Done

    gzip: /root/.cpupdates/7-23-2004.updates.gz: unexpected end of file
    Cannot fetch rpm updates list at /scripts/cPanelRPM.pm line 154.
    rsync: getaddrinfo: rsync.cpanel.net 873: Name or service not known
    rsync error: error in socket IO (code 10) at clientserver.c(83)
    Bad arg length for Socket::pack_sockaddr_in, length is 0, should be 4 at /usr/lib/perl5/5.8.1/i686-linux/Socket.pm line 373.
    ===========

    Any help is appreciated


    Regards,
    Ranish
     
  2. Christleo

    Christleo Well-Known Member

    Joined:
    Mar 13, 2003
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    Same problem here!!

    Version redhat 9.0
     
  3. ranish

    ranish Member

    Joined:
    Oct 4, 2003
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    India
    Hello,

    The issue may be because the cpanel subdomains like layer1.cpanel.net,rsync.cpanel.net etc may not be resolving from the server.


    Please check this from your end using telnet or ping commands.

    If it not resolving correct this.

    My issue got resolved after making this correct.

    You may correct this temporarily by adding the following entries in your resolv.conf file

    nameserver 69.72.164.150

    Try this out from your end.

    Enjoy
     
  4. Christleo

    Christleo Well-Known Member

    Joined:
    Mar 13, 2003
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    I can ping it have replied....?

    any idea? it seem the file can't be get...
     
  5. Christleo

    Christleo Well-Known Member

    Joined:
    Mar 13, 2003
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    Creating directory installd
    Verifying archive integrity... All good.
    Uncompressing cplyr1-cPanel.........................................................................................................................................................................
    ____ _
    ___| _ \ __ _ _ __ ___| |
    / __| |_) / _` | '_ \ / _ \ |
    | (__| __/ (_| | | | | __/ |
    \___|_| \__,_|_| |_|\___|_|

    Linux detected!
    cPanel Layer 1 Installer Init.....
    Warning !!! Warning !!! WARNING !!! Warning !!! Warning
    -------------------------------------------------------
    cPanel requires a fresh/clean server!
    If you are serving websites off this server (and are
    not already running cPanel) this installer will
    overwrite all of your config files. You should hit
    Ctrl+C NOW!!!
    If this is a new server please ignore this messages
    -------------------------------------------------------
    Warning !!! Warning !!! WARNING !!! Warning !!! Warning
    Waiting 5 seconds.....
    Done
    This install will take 10-70 minutes depending on your hardware.
    Now is the time to go get another cup of coffee/jolt.
    The install will log to /var/log/cpanel-install-thread0.log.
    and /var/log/cpanel-install-thread1.log.
    Repairing OS Problems....Done
    Installing Default resolv.conf....Done
    Installing Support Libs.Using RPM Backend: RPM version 4.2
    Fetching rpm updates list...Done

    gzip: /root/.cpupdates/8-1-2004.updates.gz: unexpected end of file
    Cannot fetch rpm updates list at cPanelRPM.pm line 154.
    Using RPM Backend: RPM version 4.2
    Fetching rpm updates list...Done

    gzip: /root/.cpupdates/8-1-2004.updates.gz: unexpected end of file
    Cannot fetch rpm updates list at cPanelRPM.pm line 154.
    Done
    Checking RPMS/DEBS...Syncing with time server....Using RPM Backend: RPM version 4.2
    Fetching rpm updates list...Done

    gzip: /root/.cpupdates/8-1-2004.updates.gz: unexpected end of file
    Cannot fetch rpm updates list at cPanelRPM.pm line 154.
    Using RPM Backend: RPM version 4.2
    Fetching rpm updates list...Done

    gzip: /root/.cpupdates/8-1-2004.updates.gz: unexpected end of file
    Cannot fetch rpm updates list at cPanelRPM.pm line 154.
    Done



    I have tried formated... same!

    Please advice..
     
Loading...

Share This Page