The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

upcp will not finish

Discussion in 'General Discussion' started by cyexx, May 12, 2008.

  1. cyexx

    cyexx Well-Known Member

    Joined:
    Sep 3, 2004
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
    I have tried upcp from web-interface and also tried from CLI with force option and it says 2 different things the CLI says 100% but it stays running for days without finishing after loading imap back. I am stuck still running

    WHM 11.15.0 cPanel 11.18.3-R21703
    FREEBSD 6.2-RELEASE i386 on standard - WHM X v3.1.0
    I am trying to push to Current so I can deal with the domain keys issues and some other features.

    I will be posting upcp log as a comment.
     
  2. cyexx

    cyexx Well-Known Member

    Joined:
    Sep 3, 2004
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
    Log Dump

    Code:
    Checking for main ip changes......Done
    Validating cPanel system users...Homedir: /usr/local/cpanel
    ...Done
    Checking and Repairing System Package Setup......Done
    Running Platform Specific Optimizations......Done
    Checking and Repairing Nameserver Config......Done
    Configuring editors......Done
    Configuring BSD make.conf......Done
    Creating symlinks for common binaries......Done
    Setting Clock......Done
    Running Env Auto Repair...quota test: repquota exited with signal 0 (ok)
    Requesting script ... Done
    Auto Repair is running...
    	io_compress_gzip has already been run.
    
    	pathtools_cpcpan has already been run.
    
    	pathtools_repair has already been run.
    Fetching http://httpupdate.cpanel.net/autofixer/check_perms4 (0)....@75.126.236.226......connected......receiving...100%......Done
    Fetching http://httpupdate.cpanel.net/autofixer/kronolith_prefs (0)....@75.126.236.226......connected......receiving...44%...89%...100%......Done
    Updating Horde kronolith preferences
    
    	phpapps_owner_fix has already been run.
    
    	spamd_dbm_fix has already been run.
    ...Auto Repair is done.
    ...Done
    Running Cleanups...Found hostname to be wakusei.****.com, which resolves to 67.19.***.***
    Hostname Virtual Host is already setup
    ...Done
    Updating services & databases...initfpsuexec: using apache 2.x support
    PHP version file is up to date
    SpamAssassin disabled in Service Manager
    Ftp Quota Check v1.6
    Updating ceo: ftp ... ...Done
    Updating cyexx: cyexx ... ftp ... ...Done
    Updating elbryan: ftp ... Can't opendir(/home/elbryan/public_ftp/incoming): Permission denied
     at /scripts/ftpquotacheck line 62
    ...Done
    Updating extreme: ftp ... ...Done
    Updating smurf: ftp ... ...Done
    ...Done
    Doing a manual update...
    Cpanel updates are coming from layer2.cpanel.net
    Setting Up Crontab......Done
    Setting Up dcpumon Crontab......Done
    Repairing Mailman Permissions......Done
    Running Sanity Checks & Notifications...pw: user 'daemon' is already locked
    ...Done
    Running Named Checks......Done
    Updating Virus Patterns......Done
    Updating FreeBSD ports...Ports are out of date.. updating....
    receiving incremental file list
    deleting INDEX-6.db
    deleting INDEX-6.bz2
    deleting INDEX-6
    deleting Tools/portbuild/scripts/build
    ./
    MOVED
    UPDATING
    ..................
    
    sent 63645 bytes  received 3281109 bytes  35394.22 bytes/sec
    total size is 195403475  speedup is 58.42
    ...Done
    Updating FTP Server...Ftp Setup Script Version 6.1
    This is the pure-ftpd installer
    Searching ports for pure-ftpd .....................................found pure-ftpd in /usr/ports/ftp/pure-ftpd....Done
    pure-ftpd (1.0.21-1) is already installed.
    ...Done
    Updating SMTP (exim) Server...Exim (maildir) Setup Script Version 20.0
    exim (4.69) is already installed.
    exim (4.69) is already installed.
    ...Done
    Updating MySQL Server...MySQL Setup Script Version 7.0
    This is the MySQL installer for OS FreeBSD
    Source: packages-6.2-release
    looking up ftp13.us.freebsd.org
    connecting to ftp13.us.freebsd.org:21
    fetch: ftp://ftp13.us.freebsd.org/pub/FreeBSD/ports/i386/packages-6.2-release/INDEX: File unavailable (e.g., file not found, no access)
    Source: packages-6-stable
    looking up ftp13.us.freebsd.org
    connecting to ftp13.us.freebsd.org:21
    binding data socket
    initiating transfer
    remote size / mtime: 16305300 / 1210058859
    /root/.cpbsdpkgs/5-12-2008.INDEX                        15 MB 1626 kBps
    mysql-client-5.0 (5.0.51) is newer then requested version 5.0.51a. (no install needed)
    mysql-server-5.0 (5.0.51) is newer then requested version 5.0.51a. (no install needed)
    Install Complete
    ...Done
    Updating bandmin...bandmin Setup Script Version 1.0
    ...Done
    Updating IMAP Server...courier-imap Setup Script Version 1.0
    This is the courier-imap installer for OS FreeBSD
    gdbm (1.8.3_3) is already installed.
    Searching ports for courier-authlib ...............................................................found courier-authlib in /usr/ports/security/courier-authlib....Done
    courier-authlib (0.60.2) is already installed.
    Searching ports for courier-imap ...............................................found courier-imap in /usr/ports/mail/courier-imap....Done
    Fetching the ports index ... --->  Session started at: Mon, 12 May 2008 15:15:50 -0400
    /usr/ports/INDEX-6.bz2                                1123 kB  873 kBps
    done
    [Updating the portsdb <format:bdb_btree> in /usr/ports ... - 18460 port entries found .........1000.........2000.........3000.........4000.........5000.........6000.........7000.........8000.........9000.........10000.........11000.........12000.........13000.........14000.........15000.........16000.........17000.........18000.... ..... done]
    ** Found already installed package(s) of 'mail/courier-imap': courier-imap-4.3.0,1
    ** None has been installed or upgraded.
    --->  Session ended at: Mon, 12 May 2008 15:16:04 -0400 (consumed 00:00:13)
    Running post install scripts for courier-imap....Done
    Detected Courier Version from binary: MAJOR=4,MINOR=3,REVISION=0
    Disabled Enhanced IDLE.  fam/gamin+inotify not detected
    Waiting for cppop to shutdown ... ...Done
    Waiting for cppop-ssl to shutdown ... ...Done
    Waiting for imap to restart..............finished.
    
    root     49964  0.0  0.1  1268   628  ??  S     3:16PM   0:00.00 /usr/local/sbin/courierlogger -pid=/var/run/imapd-ssl.pid -start -name=imapd-ssl /usr/local/libexec/courier-imap/couriertcpd -address=0 -maxprocs=50 -maxperip=30 -nodnslookup -noidentlookup 993 /usr/local/bin/couriertls -server -tcpd /usr/local/sbin/imaplogin /usr/local/bin/imapd Maildir
    root     49965  0.0  0.1  1332   736  ??  S     3:16PM   0:00.00 /usr/local/libexec/courier-imap/couriertcpd -address=0 -maxprocs=50 -maxperip=30 -nodnslookup -noidentlookup 993 /usr/local/bin/couriertls -server -tcpd /usr/local/sbin/imaplogin /usr/local/bin/imapd Maildir
    root     49978  0.0  0.1  1268   628  ??  S     3:16PM   0:00.00 /usr/local/sbin/courierlogger -pid=/var/run/imapd.pid -start -name=imapd /usr/local/libexec/courier-imap/couriertcpd -address=0 -maxprocs=50 -maxperip=30 -nodnslookup -noidentlookup 143 /usr/local/sbin/imaplogin /usr/local/bin/imapd Maildir
    root     49979  0.0  0.1  1332   736  ??  S     3:16PM   0:00.00 /usr/local/libexec/courier-imap/couriertcpd -address=0 -maxprocs=50 -maxperip=30 -nodnslookup -noidentlookup 143 /usr/local/sbin/imaplogin /usr/local/bin/imapd Maildir
    root     49991  0.0  0.1  1268   628  ??  S     3:16PM   0:00.00 /usr/local/sbin/courierlogger -pid=/var/run/pop3d-ssl.pid -start -name=pop3d-ssl /usr/local/libexec/courier-imap/couriertcpd -address=0 -maxprocs=50 -maxperip=30 -nodnslookup -noidentlookup 995 /usr/local/bin/couriertls -server -tcpd /usr/local/sbin/pop3login /usr/local/bin/pop3d Maildir
    root     49992  0.0  0.1  1332   736  ??  S     3:16PM   0:00.00 /usr/local/libexec/courier-imap/couriertcpd -address=0 -maxprocs=50 -maxperip=30 -nodnslookup -noidentlookup 995 /usr/local/bin/couriertls -server -tcpd /usr/local/sbin/pop3login /usr/local/bin/pop3d Maildir
    root     50004  0.0  0.1  1272   644  ??  S     3:16PM   0:00.00 /usr/local/sbin/courierlogger -pid=/var/run/pop3d.pid -start -name=pop3d /usr/local/libexec/courier-imap/couriertcpd -address=0 -maxprocs=50 -maxperip=30 -nodnslookup -noidentlookup 110 /usr/local/sbin/pop3login /usr/local/bin/pop3d Maildir
    root     50005  0.0  0.1  1332   768  ??  S     3:16PM   0:00.00 /usr/local/libexec/courier-imap/couriertcpd -address=0 -maxprocs=50 -maxperip=30 -nodnslookup -noidentlookup 110 /usr/local/sbin/pop3login /usr/local/bin/pop3d Maildir
    root     49945  0.0  0.1  1272   676  ??  S     3:16PM   0:00.00 /usr/local/sbin/courierlogger -facility=mail -pid=/var/run/authdaemond/pid -start /usr/local/libexec/courier-authlib/authdaemond
    root     49946  0.0  0.1  1472   816  ??  S     3:16PM   0:00.00 /usr/local/libexec/courier-authlib/authdaemond
    root     49948  0.0  0.1  1472   824  ??  S     3:16PM   0:00.00 /usr/local/libexec/courier-authlib/authdaemond
    root     49949  0.0  0.1  1472   816  ??  S     3:16PM   0:00.00 /usr/local/libexec/courier-authlib/authdaemond
    root     49950  0.0  0.1  1472   816  ??  S     3:16PM   0:00.00 /usr/local/libexec/courier-authlib/authdaemond
    root     49951  0.0  0.1  1472   816  ??  S     3:16PM   0:00.00 /usr/local/libexec/courier-authlib/authdaemond
    root     49952  0.0  0.1  1472   816  ??  S     3:16PM   0:00.00 /usr/local/libexec/courier-authlib/authdaemond
    
    imap started ok
    Install Complete
    
     
  3. Fernis

    Fernis Well-Known Member

    Joined:
    Oct 28, 2006
    Messages:
    192
    Likes Received:
    1
    Trophy Points:
    18
    Check to make sure register_globals are turned off.

    /etc/php.ini I think is the location. Please correct me if I am wrong.
     
  4. cyexx

    cyexx Well-Known Member

    Joined:
    Sep 3, 2004
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
    no go

    i changed /scripts/php.ini and /usr/lib/php.ini to have globals off and re-ran upcp --force with same problem hangs in the same spot.

    ps -A | grep upcp
    73380 ?? Is 0:00.09 cPanel Update (upcp) - Slave (perl5.8.8)
     
  5. tprice42

    tprice42 Active Member

    Joined:
    Sep 10, 2004
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    Any progress on this issue? I've got exactly the same problem on exactly the same platform and cPanel / WHM version.
     
  6. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    This issue has been resolved in later builds of cPanel/WHM. In the meantime, you may want to have our technical analysts look at your server to assist with overcoming this technical issue.
     
Loading...

Share This Page