The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

upcp woes..

Discussion in 'General Discussion' started by beddo, Feb 4, 2008.

  1. beddo

    beddo Well-Known Member

    Joined:
    Jan 19, 2007
    Messages:
    157
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    England
    cPanel Access Level:
    DataCenter Provider
    Well I was kept up to the wee hours last night.
    I wanted to put XMLReader support into my PHP (4.4.6 with apache 1.3).

    I ran upcp first then tried to use the new easyapache without changing versions. Woops
    Apache coredumped. It seems like it was trying to use /usr/local/lib/libcrypto.so.3. I only have .so and .so.5 on my system.

    After a few hours arsing around I gave up. I upgraded to PHP 4.4.8 with no effect so then went to the Apache 2.0 tree. This stopped the core dumps.

    Apache is back up and running, but I'm finding some things not working. The main one is some databases through PHP:

    Current versions are:

    WHM 11.15.0 cPanel 11.17.5-C20439
    FREEBSD 6.2-RELEASE amd64 on standard - WHM X v3.1.0

    From what I read, this can be solved by adding --old-passwords to the mysqld runtime flags. The problem is, I can't figure out where to add these to make Cpanel obey it.

    /etc/rc.conf gets ignored.
    Putting it directly into /usr/local/etc/rc.d/mysql-server also gets ignored.

    I don't want to upgrade PHP to 5 without being sure that it isn't going to break loads of scripts..can anyone point me in the right direction?

    Cheers.
     
  2. jayh38

    jayh38 Well-Known Member

    Joined:
    Mar 3, 2006
    Messages:
    1,215
    Likes Received:
    0
    Trophy Points:
    36
    For old passwords option, this would go in /etc/my.cnf under the [MYSQLD] section:

    old-password=1

    or in whm > server configuration > tweak settings > mysql > tick the box "Use old style (4.0) passwords with MySQL® 4.1+ (required if you have problems with PHP apps authenticating)"
     
  3. beddo

    beddo Well-Known Member

    Joined:
    Jan 19, 2007
    Messages:
    157
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    England
    cPanel Access Level:
    DataCenter Provider
    Thanks for the reply, unfortunately neither of these seems to affect the problem (I have restarted both mysql and apache since changing them).

    Mysql is:
    I guess the message is coming up for some other reason...
     
  4. jayh38

    jayh38 Well-Known Member

    Joined:
    Mar 3, 2006
    Messages:
    1,215
    Likes Received:
    0
    Trophy Points:
    36
    Did you try
    /scripts/mysqlup --force

    That should update everything properly and get you running.
     
  5. beddo

    beddo Well-Known Member

    Joined:
    Jan 19, 2007
    Messages:
    157
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    England
    cPanel Access Level:
    DataCenter Provider
    I hadn't tried that. I know there was an update in the ports tree.
    I have however now tried that and it has made no difference at all.
    It isn't affecting everything as some sites work and some don't. I have an OS Commerce site which works (thank god, that's the most important one on the server!). I have a phpbb site and a wbb site that don't..
     
  6. beddo

    beddo Well-Known Member

    Joined:
    Jan 19, 2007
    Messages:
    157
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    England
    cPanel Access Level:
    DataCenter Provider
    It looks like some of my accounts have new passwords and some of my accounts have old passwords. Only the ones with old passwords work regardless of whether mysql is told to use old passwords or not..

    At least I'm getting closer to the answer, previously I must have had both old and new passwords working side by side so need to get that back otherwise everyone is going to have to change their passwords to get the same type..not good!
     
  7. davidC

    davidC Member

    Joined:
    Aug 18, 2005
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Keep us posted, I woke up to this today too. Clients not too happy =/
     
  8. beddo

    beddo Well-Known Member

    Joined:
    Jan 19, 2007
    Messages:
    157
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    England
    cPanel Access Level:
    DataCenter Provider
    Workaround at the moment is to turn on old passwords and then have the user update their password. It'll create an old password which will work. I still have absolutely no idea why the server is able to generate and store new passwords but not verify authorisations that try to use them.

    Not heard anything from the MySQL forums either as it is not expected behaviour. Regardless of the old passwords setting, MySQL should always be able to verify against any passwords that are stored in the new password format so something is broken, I just don't know what.

    What OS and CPanel are you using? Just wondering if there is anything common..
     
  9. davidC

    davidC Member

    Joined:
    Aug 18, 2005
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    I just deleted the db users and recreated them with the same password

    CENTOS Enterprise 4.6
    WHM 11.15.0

    The night before i upgraded to PHP 4.4.8 with EA3 but I was thinking it was just a coincidence.
    I do know when i tried to restart mysqld I got the following
    "Can't create a new thread (errno 12); if you are not out of available =
    memory, you can consult the manual for a possible OS-dependent bug at =
    /scripts/optimize_eximstats line 23

    ...Done
    "
    All my DBs were down but then they eventually came up.
     
  10. beddo

    beddo Well-Known Member

    Joined:
    Jan 19, 2007
    Messages:
    157
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    England
    cPanel Access Level:
    DataCenter Provider
    I didn't get that error at all.
    If I was to reset all my user's passwords, they would all get passwords set in the old less secure type. I have manually reset the important ones to old passwords but I would much rather fix the problem than bodge round it by resetting everyone to an old style password.
    Generating a new hash for new style passwords still produces an unusable result.

    Getting nowhere with this unfortunately :(
     
  11. beddo

    beddo Well-Known Member

    Joined:
    Jan 19, 2007
    Messages:
    157
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    England
    cPanel Access Level:
    DataCenter Provider
    One step further.

    I know believe this is a PHP problem. For some reason I never tried to log in to the various accounts from anything other than PHP. Having done that I see that the authentication is working fine but PHP would appear to be using the wrong mysql cilent libraries. I can only assume easyapache is screwing up the build. It is either trying to use the wrong one, using the bundled version or just broken.

    I know there is a build option for compiling php mysql support against system libraries instead of the bundled ones. I'm quite sure I tried that at some point though I'm not sure whether that was whilst Apache was coredumping or not.

    I shall try it again in the morning and report back rather than risk breaking things again when I should be going to bed.
     
  12. beddo

    beddo Well-Known Member

    Joined:
    Jan 19, 2007
    Messages:
    157
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    England
    cPanel Access Level:
    DataCenter Provider
    Ok, so an upcp and a new easyapache with PHP compiled against the system libraries has got it all working again. Its always something simple, the problem is knowing what!
     
Loading...

Share This Page