The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Update Apache errors - symlink & servername

Discussion in 'EasyApache' started by jeroman8, Nov 29, 2006.

  1. jeroman8

    jeroman8 Well-Known Member

    Joined:
    Mar 14, 2003
    Messages:
    410
    Likes Received:
    0
    Trophy Points:
    16
    Arrgh...

    trying to compile apache - php4 and apache 1.3.
    tried different cpanel builds and from WHM and shell.
    Does not work and the errors I can see during rebuild is below.

    Anyone ?


    Error: postcheck() returned a faild status
    Leaving build intact so that the configuration can be manually fixed

    Use of uninitialized value in -e at /usr/lib/perl5/site_perl/5.8.7/File/Copy/Recursive.pm line 184.
    Copying a symlink (/usr/local/apache/conf.1.orig/) whose target does not exist at /usr/local/cpanel/Cpanel/cPanelFunctions.pm line 755
    Could not determine user for ServerName srv05.domain11.com at /usr/lib/perl5/site_perl/5.8.7/Apache/Admin/Config.pm line 217
    Could not determine user for ServerName 329300026.domain22.se at /usr/lib/perl5/site_perl/5.8.7/Apache/Admin/Config.pm line 217
    httpd.conf SRC: 1 TRG: 1
    Can't locate auto/cPScript/SafeRun/saferun_out.al in @INC (@INC contains: /usr/local/cpanel /scripts /home/cpeasyapache/work /usr/lib/perl5/5.8.7/i686-linux /usr/lib/perl5/5.8.7 /usr/lib/perl5/site_perl/5.8.7/i686-linux /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl .) at /usr/local/cpanel/Cpanel/EasyApache/HttpdConf.pm line 1459
    Coercing apachectl...
     
  2. jeroman8

    jeroman8 Well-Known Member

    Joined:
    Mar 14, 2003
    Messages:
    410
    Likes Received:
    0
    Trophy Points:
    16
    Trying to do withour curlSSL and openSSL now but the servername erros bugs me.
    It's one old servername I guess + the hostname I got it with from the noc.

    I have changed the hostname in WHM and checked /etc/hosts - it's my new hostname there
    but according to errors above 2 other hostnames is there.

    Or is servername here referring to something else....
     
Loading...

Share This Page