The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Update Apache or easyapache not working!

Discussion in 'EasyApache' started by jeroman8, Mar 12, 2007.

  1. jeroman8

    jeroman8 Well-Known Member

    Joined:
    Mar 14, 2003
    Messages:
    410
    Likes Received:
    0
    Trophy Points:
    16
    This has been going on for a while now on multiple servers and builds.

    You choose update apache in WHM with eaither a new php build or just a new php module - WHM says update is complete and restarted apache OK.

    BUT Nothing has been changed at all !!!

    Same thing if you do it with SSH/easyapache!

    What do I have that is different from all the rest of you?
    Sure, some post problems here, same thing but not many and no fixes.
    I tested remove mod_Security, ZEND, eaccelerator before I ran it but
    it did not help.
    Sometime it has helped to remove/not choose IMAP support in PHP,
    but that breaks webmail so...
    I read in a thread that if you downgrade mysql it will help - hm, it really should work anyway.

    It's really important tp upgrade php to 4.4.6 since all the exploits/bypass etc has
    been fixed - it's a security update mostly.
    But it's really not fun have to spend so much time compiling all from scratch
    3-4 times before it works.
     
  2. katmai

    katmai Well-Known Member

    Joined:
    Mar 13, 2006
    Messages:
    526
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Brno, Czech Republic
    1 - easyapache works prettu much fine from the first shot.

    2 - i will repost what i said in another thread:

    as a system admin, or business manager, it is your job to make sure that your sole security is not based on how up2date are the applications are, and who will try to beat me on this, should think again.

    the security on a server should be done in layers. kernel hardening/cpanel restriction/php hardening/apache hardening

    you cannot just say that IS A MUST to upgrade to the 4.4.5 version, when you stayed like how many ? 4 5 months with php 4.4.4 and you thought yourself that you are up2date and yet funny thing imagine that there was some vulnerable stuff in it, you absolutely have no idea. and now as they proudly release the new code, you say wow we MUST upgrade it is highly recommended. come on. get serious guys.

    risk analysys, good business planning and a few more stuff are the key for a stable business.
     
Loading...

Share This Page