masterross

Well-Known Member
Apr 7, 2004
67
3
158
Hi,
cp update cant pass - cPanel & WHM update failure in upcp script

Code:
=> Log opened from /usr/local/cpanel/scripts/updatenow (12043) at Fri Apr 16 03:52:04 2021
[2021-04-16 03:52:04 +0300] Running version '11.94.0.4' of updatenow.
[2021-04-16 03:52:05 +0300] Retrieved public key from vendor: cpanel, category: release, url: https://securedownloads.cpanel.net/cPanelPublicKey.asc
[2021-04-16 03:52:05 +0300] Retrieved public key from vendor: cpanel, category: development, url: https://securedownloads.cpanel.net/cPanelDevelopmentKey.asc
[2021-04-16 03:52:05 +0300] Detected version '11.94.0.4' from version file.
[2021-04-16 03:52:06 +0300] Target version set to '11.94.0.4'
[2021-04-16 03:52:06 +0300] Up to date (11.94.0.4)
=> Log closed Fri Apr 16 03:52:06 2021
[2021-04-16 03:52:06 +0300] 17% complete
=> Log closed Fri Apr 16 03:52:06 2021
cPanel version change from “11.94.0.4” to “11.94.0.4” is blocked

Code:
[2021-04-16 12:47:52 +0300] eval {...} called at /usr/local/cpanel/Cpanel/Update/Blocker/Always.pm line 764
[2021-04-16 12:47:52 +0300] Cpanel::Update::Blocker::Always::_get_sysinfo(Cpanel::Update::Blocker=HASH(0x3942988)) called at /usr/local/cpanel/Cpanel/Update/Blocker/Always.pm line 745
[2021-04-16 12:47:52 +0300] Cpanel::Update::Blocker::Always::is_supported_openssl(Cpanel::Update::Blocker=HASH(0x3942988)) called at /usr/local/cpanel/Cpanel/Update/Blocker/Always.pm line 104
[2021-04-16 12:47:52 +0300] Cpanel::Update::Blocker::Always::perform_global_checks(Cpanel::Update::Blocker=HASH(0x3942988)) called at /usr/local/cpanel/Cpanel/Update/Blocker.pm line 74
[2021-04-16 12:47:52 +0300] Cpanel::Update::Blocker::is_upgrade_blocked(Cpanel::Update::Blocker=HASH(0x3942988)) called at /usr/local/cpanel/Cpanel/Update/Now.pm line 699
[2021-04-16 12:47:52 +0300] Cpanel::Update::Now::can_update(Cpanel::Update::Now=HASH(0x36e2638)) called at /usr/local/cpanel/Cpanel/Update/Now.pm line 408
[2021-04-16 12:47:52 +0300] Cpanel::Update::Now::run(Cpanel::Update::Now=HASH(0x36e2638)) called at /usr/local/cpanel/scripts/updatenow line 122
[2021-04-16 12:47:52 +0300] eval {...} called at /usr/local/cpanel/scripts/updatenow line 122
[2021-04-16 12:47:53 +0300] W An attempt to upgrade to 11.94.0.4 was blocked. Please review blockers.
[2021-04-16 12:47:53 +0300] E The install encountered a fatal error: An attempt to upgrade to 11.94.0.4 was blocked. Please review blockers.
=> Log closed Fri Apr 16 12:47:53 2021
[2021-04-16 12:47:53 +0300] 17% complete
=> Log closed Fri Apr 16 12:47:53 2021
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
6,081
777
313
cPanel Access Level
Root Administrator
Thanks for providing these details. There should be more details in the log that show what the blocker is. Can you check the update log, which would be located in /var/cpanel/updatelogs, to see if you can find the full reason it is not updating?
 

masterross

Well-Known Member
Apr 7, 2004
67
3
158
Hi, just saw " Your RPM database appears unstable. It is not possible at the moment to install a simple RPM. "

So I've rebuilt it and the update went OK.
Thanks for the support!