Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Update blocker “ea-apache24-config-runtime”

Discussion in 'General Discussion' started by Killer_Awesome, Feb 18, 2018.

  1. Killer_Awesome

    Killer_Awesome Registered

    Joined:
    Feb 18, 2018
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Australia
    cPanel Access Level:
    Root Administrator
    Hi,

    I'm kinda new to WHM webhosting so i'm still learning how it all works any way i'm trying to update cpanel but i keep getting stuck by the below error i have tried a few thing but none of them have seemed to work so far. Any help would be greatly appreciated as it have been trying to work this out for a few weeks now. If you need any more info please let me know


    Error:
    You must upgrade the EasyApache 4 package, “ea-apache24-config-runtime”, to version 1.0-113 or later to upgrade cPanel & WHM. (The template file “/var/cpanel/templates/apache2_4/ssl_vhost.default” needs the “SSLCertificateKeyFile” changes that 1.0-113 made.

    I have tried:
    • yum update
    • yum upgrade
    • /scripts/upcp --force
    • yum reinstall ea-apache24-config-runtime.noarch

    Sytem info:
    Centos 7.4.1708
    Cpanel: v66.0.35

    Thank you
     
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    47,529
    Likes Received:
    2,181
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    Do you notice any error messages or output when running the "yum update" command on this system?

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Killer_Awesome

    Killer_Awesome Registered

    Joined:
    Feb 18, 2018
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Australia
    cPanel Access Level:
    Root Administrator
    Hi

    Their is no errors when i run the command.

    console:
    # yum update
    Loaded plugins: fastestmirror, universal-hooks
    EA4 | 2.3 kB 00:00:00
    cpanel-addons-production-feed | 2.9 kB 00:00:00
    base | 3.6 kB 00:00:00
    extras | 3.4 kB 00:00:00
    updates | 3.4 kB 00:00:00
    Loading mirror speeds from cached hostfile
    * cpanel-addons-production-feed: 103.252.152.1
    * base: mirror.ventraip.net.au
    * extras: mirror.ventraip.net.au
    * updates: mirror.ventraip.net.au
    No packages marked for update


    Thank you
     
  4. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    47,529
    Likes Received:
    2,181
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    Could you open a support ticket using the link in my signature so we can take a closer look?

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Mohammed Mimi

    Mohammed Mimi Registered

    Joined:
    Feb 26, 2018
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Amman
    cPanel Access Level:
    Website Owner
    Hello dear michael ,
    i have same error can you help me please for solve this error !
    regards
     
  6. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    47,529
    Likes Received:
    2,181
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    Try running the following command and let us know the output:

    Code:
    yum update ea-apache24-config-runtime
    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. RudiBoot

    RudiBoot Registered

    Joined:
    May 20, 2018
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Sheffield
    cPanel Access Level:
    Website Owner
    Hi, I'm having the same issue, I've tried the above and i get
    No Packages marked for Update.

    here is my config
    • CENTOS 6.9 kvm [731387]
    • v66.0.35
    Any idea what i should do
     
    #7 RudiBoot, May 20, 2018
    Last edited by a moderator: May 20, 2018
  8. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    47,529
    Likes Received:
    2,181
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello @RudiBoot,

    Can you open a support ticket using the link in my signature so we can take a closer look? You can post the ticket number here and we will link this thread to your ticket.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. wgc_panelc

    wgc_panelc Registered

    Joined:
    Apr 18, 2019
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    TX
    cPanel Access Level:
    Root Administrator
    One more that is experiencing this issue. Will "yum reinstall apache24-config-runtime" take care of the issue?
     
  10. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    47,529
    Likes Received:
    2,181
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Running the "yum update" command on the system should generally install the updated apache24-config-runtime RPM automatically. If that's not happening, it suggests there's something preventing YUM from updating the system's packages. Can you run the following commands on the affected system and let us know the output?

    Code:
    perl -v
    cat /etc/redhat-release
    grep exclude= /etc/yum.conf
    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. wgc_panelc

    wgc_panelc Registered

    Joined:
    Apr 18, 2019
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    TX
    cPanel Access Level:
    Root Administrator

    perl is 5.10.1
    Centos release 6.10 final
    and
    exclude=bind-chroot courier* dovecot* exim* filesystem httpd* mod_ssl* mydns* mysql* nsd* p0f php* profited* pure-ftpd* spamassassin* squirrelmail*
    is httpd* in the exclude statement interfering?
     
  12. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    47,529
    Likes Received:
    2,181
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello @wgc_panelc,

    The httpd* entry on the EXCLUDE= line in /etc/yum.conf is normal and will not interfere with the EasyApache 4 RPMs.

    Can you open a support ticket so we can take a closer look at your system to see why YUM is unable to update the ea-apache24-config-runtime RPM? You can post the ticket number here and we'll link this thread to it.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice