rlshosting

Well-Known Member
Apr 23, 2009
170
1
68
United States
cPanel Access Level
Root Administrator
I am trying to run /scripts/upcp and it errors every time. How do I fix this? Thank you.

Code:
[20130330.180522]      [4410] /usr/sbin/prelink: /opt/tidy/lib/libtidy-0.99.so.0.0.0 is not present in any config file directories, nor was specified on command line
[20130330.180522]      [4410] /usr/sbin/prelink: /opt/libmcrypt/lib/libmcrypt.so.4.4.8 is not present in any config file directories, nor was specified on command line
[20130330.180522]      [4410] /usr/sbin/prelink: /usr/local/cpanel/3rdparty/perl/514/lib64/perl5/5.14.3/x86_64-linux-64int/CORE/libperl.so is not present in any config file directories, nor was specified on command line
[20130330.180522]      [4410] /usr/sbin/prelink: /opt/xml2/lib/libxml2.so.2.9.0 is not present in any config file directories, nor was specified on command line
[20130330.180522]      [4410] /usr/sbin/prelink: /opt/curlssl/lib/libcurl.so.4.2.0 is not present in any config file directories, nor was specified on command line
[20130330.180522]      [4410] /usr/sbin/prelink: /usr/local/cpanel/3rdparty/lib64/libpcre.so.1.0.1 is not present in any config file directories, nor was specified on command line
[20130330.180522]      [4410] /usr/sbin/prelink: /opt/pcre/lib/libpcre.so.0.0.1 is not present in any config file directories, nor was specified on command line
[20130330.180522]      [4410] /usr/sbin/prelink: /usr/local/cpanel/3rdparty/lib64/libspf2.so.2.1.0 is not present in any config file directories, nor was specified on command line
[20130330.180522]      [4410] /usr/sbin/prelink: /usr/local/cpanel/3rdparty/lib64/libsrs_alt.so.1.0.0 is not present in any config file directories, nor was specified on command line
[20130330.180522]      [4410] /usr/sbin/prelink: Could not prelink /usr/bin/giftogd2 because it doesn't use /lib64/libexpat.so.1, but one of its dependencies has been prelinked against it
[20130330.180522]      [4410] /usr/sbin/prelink: Could not prelink /usr/bin/rsvg-convert because it doesn't use /lib64/libexpat.so.1, but one of its dependencies has been prelinked against it
[20130330.180522]      [4410] /usr/sbin/prelink: Could not rename temporary to /bin/gzip: Operation not permitted
[20130330.180522]      [4410] /usr/sbin/prelink: Could not prelink /usr/bin/gdcmpgif because it doesn't use /lib64/libexpat.so.1, but one of its dependencies has been prelinked against it
[20130330.180522]      [4410] /usr/sbin/prelink: Could not prelink /usr/bin/gd2togif because it doesn't use /lib64/libexpat.so.1, but one of its dependencies has been prelinked against it
[20130330.180522]      [4410] /usr/sbin/prelink: Could not prelink /usr/bin/gd2topng because it doesn't use /lib64/libexpat.so.1, but one of its dependencies has been prelinked against it
[20130330.180522]      [4410] /usr/sbin/prelink: Could not prelink /usr/bin/php because its dependency /opt/tidy/lib/libtidy-0.99.so.0 could not be prelinked
[20130330.180522]      [4410] /usr/sbin/prelink: Could not prelink /usr/bin/gd2copypal because it doesn't use /lib64/libexpat.so.1, but one of its dependencies has been prelinked against it
[20130330.180522]      [4410] /usr/sbin/prelink: Could not prelink /usr/bin/pngtogd because it doesn't use /lib64/libexpat.so.1, but one of its dependencies has been prelinked against it
[20130330.180522]      [4410] /usr/sbin/prelink: Could not prelink /usr/bin/gdtopng because it doesn't use /lib64/libexpat.so.1, but one of its dependencies has been prelinked against it
[20130330.180522]      [4410] /usr/sbin/prelink: Could not prelink /usr/bin/pngtogd2 because it doesn't use /lib64/libexpat.so.1, but one of its dependencies has been prelinked against it
[20130330.180522]      [4410] /usr/sbin/prelink: Could not prelink /usr/sbin/exim because its dependency /usr/local/cpanel/3rdparty/lib64/libspf2.so.2 could not be prelinked
[20130330.180522]      [4410] /usr/sbin/prelink: Could not prelink /usr/bin/annotate because it doesn't use /lib64/libexpat.so.1, but one of its dependencies has been prelinked against it
[20130330.180522]      [4410] /usr/sbin/prelink: Could not prelink /usr/bin/gdparttopng because it doesn't use /lib64/libexpat.so.1, but one of its dependencies has been prelinked against it
[20130330.180522]      [4410] /usr/sbin/prelink: Could not prelink /usr/bin/webpng because it doesn't use /lib64/libexpat.so.1, but one of its dependencies has been prelinked against it
[20130330.180522]      [4410] /usr/sbin/prelink: Could not prelink /usr/bin/rsvg-view because it doesn't use /lib64/libexpat.so.1, but one of its dependencies has been prelinked against it
 
Last edited:

mtindor

Well-Known Member
Sep 14, 2004
1,363
65
178
inside a catfish
cPanel Access Level
Root Administrator
I wonder if this is really the right way to go about "resolving" that issue. I get the same warnings when I attempt to Update System Software.

Cpanel Staff: What's the best way of handling this? Ignore it?
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,607
76
308
cPanel Access Level
Root Administrator
I wonder if this is really the right way to go about "resolving" that issue. I get the same warnings when I attempt to Update System Software.

Cpanel Staff: What's the best way of handling this? Ignore it?
For now it is needless noise. I believe we suppress the noise in 11.36.1.

We attempt to run the prelink utility, when it is installed, to prevent other false negatives from the check_cpanel_rpms script. Unfortunately on some systems running the prelink utility causes other noise, as demonstrated in this thread.
 

p123

Member
Aug 20, 2011
17
0
51
Bangkok
I've noted the same thing here earlier today.

When trying to run Update Server Software I get:

Code:
cPanel Package Upgrades in Progress...

scripts/ftpup is deprecated. ftp is now updated by the rpm.versions system when you run upcp.
scripts/mysqlup is deprecated. mysql is now updated by the rpm.versions system when you run upcp.
scripts/bandminup is deprecated. bandmin is now updated by the rpm.versions system when you run upcp.
scripts/imapup is deprecated. imap is now updated by the rpm.versions system when you run upcp.
scripts/nsdup is deprecated. nsd is now updated by the rpm.versions system when you run upcp.
scripts/eximup is deprecated. exim is now updated by the rpm.versions system when you run upcp.
  All Needed RPMS are installed.
Complete
and Update System Software gives me:

Code:
checkyum version 21.1
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.muntinternet.net
 * extras: mirror.muntinternet.net
 * updates: mirror.muntinternet.net
Excluding Packages in global exclude list
Finished
Setting up Update Process
No Packages marked for Update
/usr/sbin/prelink: /usr/local/cpanel/3rdparty/perl/514/lib64/perl5/5.14.3/x86_64-linux-64int/CORE/libperl.so is not present in any config file directories, nor was specified on command line
/usr/sbin/prelink: /usr/local/cpanel/3rdparty/lib64/libpcre.so.1.0.1 is not present in any config file directories, nor was specified on command line
/usr/sbin/prelink: /opt/libmcrypt/lib/libmcrypt.so.4.4.8 is not present in any config file directories, nor was specified on command line
/usr/sbin/prelink: /opt/xml2/lib/libxml2.so.2.9.0 is not present in any config file directories, nor was specified on command line
/usr/sbin/prelink: /opt/curlssl/lib/libcurl.so.4.2.0 is not present in any config file directories, nor was specified on command line
/usr/sbin/prelink: /opt/xslt/lib/libexslt.so.0.8.16 is not present in any config file directories, nor was specified on command line
/usr/sbin/prelink: /opt/pcre/lib/libpcre.so.0.0.1 is not present in any config file directories, nor was specified on command line
/usr/sbin/prelink: /usr/local/cpanel/3rdparty/lib64/libspf2.so.2.1.0 is not present in any config file directories, nor was specified on command line
/usr/sbin/prelink: /opt/xslt/lib/libxslt.so.1.1.27 is not present in any config file directories, nor was specified on command line
/usr/sbin/prelink: /usr/local/cpanel/3rdparty/lib64/libsrs_alt.so.1.0.0 is not present in any config file directories, nor was specified on command line
/usr/sbin/prelink: Could not prelink /usr/sbin/exim because its dependency /usr/local/cpanel/3rdparty/lib64/libspf2.so.2 could not be prelinked
/usr/sbin/prelink: Could not prelink /usr/bin/php because its dependency /opt/xslt/lib/libexslt.so.0 could not be prelinked
checkyum version 21.1
Is this anything to be worried about ? Will it be resolved in the next update or should I contact cPanel support? Some advise would be greatly appreciated.