The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Update cPanel 11.36.0.4 to 11.36.0.6 error obselete curl-devel

Discussion in 'General Discussion' started by blade3, Feb 8, 2013.

  1. blade3

    blade3 Registered

    Joined:
    Feb 8, 2013
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I'm trying to update CPANEL using WHM.. and i got this error..

    Code:
    [20130208.081251] 0% complete [20130208.081251] Detected cron=0 (env var CPANEL_IS_CRON was present before this process started.) [20130208.081251] 1% complete ----------------------------------------------------------------------------------------------------
    => Log opened from /scripts/upcp at Fri Feb  8 08:12:51 2013
    [20130208.081251]   Detected cron=0 (env var CPANEL_IS_CRON was present before this process started.)
    [20130208.081251]   Running Standardized hooks
    => Log closed Fri Feb  8 08:12:51 2013
    [20130208.081252]   mtime on upcp is 1359439019 (Tue Jan 29 00:56:59 2013)
    ----------------------------------------------------------------------------------------------------
    => Log opened from /usr/local/cpanel/scripts/updatenow at Fri Feb  8 08:12:52 2013
    [20130208.081252]   Detected version '11.36.0.4' from version file.
    [20130208.081252]   Target version set to '11.36.0.6'
    [20130208.081252]   Switching to 11.36.0.6 to determine if we can reach that version without failure.
    [20130208.081252]   Retrieving and staging /cpanelsync/11.36.0.6/cpanel/scripts/updatenow.static.bz2
    [20130208.081252]   Using mirror: 67.205.110.4
    [20130208.081252]   Set permissions on /usr/local/cpanel/scripts/updatenow.static-cpanelsync to 0700
    => Log closed Fri Feb  8 08:12:52 2013
    ----------------------------------------------------------------------------------------------------
    => Log opened from /usr/local/cpanel/scripts/updatenow.static-cpanelsync at Fri Feb  8 08:12:52 2013
    [20130208.081252]   Detected version '11.36.0.4' from version file.
    [20130208.081252]   Target version set to '11.36.0.6'
    [20130208.081252]   Checking license
    [20130208.081252]   License file check complete
    [20130208.081252]   Checking that the RPM DB is OK...
    [20130208.081252]   glibc-2.5-107
    [20130208.081252]   glibc-2.5-107
    [20130208.081252]   OK: RPM DB is responding to queries
    [20130208.081252]   Testing if rpm_is_working RPM is installed
    [20130208.081252]   package rpm_is_working is not installed
    [20130208.081252]   Testing if it's possible to install a simple RPM
    [20130208.081252]   Preparing...                ##################################################
    [20130208.081252]   rpm_is_working              ##################################################
    [20130208.081252]   Switching to version '11.36.0.6' of updatenow to perform sync.
    [20130208.081254]   Loaded plugins: fastestmirror, security
    [20130208.081254]   Loading mirror speeds from cached hostfile
    [20130208.081254]    * base: centos.mirror.iweb.ca
    [20130208.081254]    * epel: fedora.mirror.nexicom.net
    [20130208.081254]    * extras: centos.mirror.iweb.ca
    [20130208.081254]    * remi: remi-mirror.dedipower.com
    [20130208.081254]    * updates: centos.mirror.netelligent.ca
    [20130208.081255]   Excluding Packages in global exclude list
    [20130208.081257]   Finished
    [20130208.081257]   Setting up Install Process
    [U][20130208.081257]   Package curl-devel is obsoleted by libcurl-devel, trying to install libcurl-devel-7.21.7-5.el5.remi.2.x86_64 instead
    [20130208.081257]   Package libcurl-devel-7.21.7-5.el5.remi.2.x86_64 already installed and latest version
    [20130208.081257]   Package curl-devel is obsoleted by libcurl-devel, trying to install libcurl-devel-7.21.7-5.el5.remi.2.x86_64 instead
    [20130208.081257]   Package libcurl-devel-7.21.7-5.el5.remi.2.x86_64 already installed and latest version
    [20130208.081257]   Nothing to do
    [20130208.081258] E Sysup: Needed system RPMs were not installed: curl-devel
    [20130208.081258] ***** FATAL: Cannot proceed. Needed system RPMs were not installed.[/U]
    [20130208.081258]   The Administrator will be notified to review this output when this script completes
    [20130208.081258] E Detected events which require user notification during updatenow. Will send iContact the log
    => Log closed Fri Feb  8 08:12:58 2013
    [20130208.081258] E Running `/usr/local/cpanel/scripts/updatenow --upcp --log=/var/cpanel/updatelogs/update.1360329171.log` failed, exited with code 18 (signal = 0)
    => Log closed Fri Feb  8 08:12:58 2013

    any idea ?

    thanks
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,811
    Likes Received:
    671
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    The update script could not proceed because it could not install the RPM for "curl-devel". You can run the following command to see which curl RPMs are installed on your system:

    Code:
    # rpm -qa|grep curl
    Do you have any third-party repos listed in the "/etc/yum.repos.d" directory? You can check via:

    Code:
    # ls /etc/yum.repos.d/
    You can also submit a ticket if you want us to take a closer look:

    Submit A Ticket

    Remember to post the ticket number here if you decide to open one.

    Thank you.
     
  3. blade3

    blade3 Registered

    Joined:
    Feb 8, 2013
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi back, thanks for answering how question, here is what i got back from a preview

    result:

    Code:
    [~]# rpm -qa|grep curl
    compat-libcurl3-7.15.5-2.el5.remi
    curl-7.15.5-15.el5
    curl-7.21.7-5.el5.remi.2
    libcurl-devel-7.21.7-5.el5.remi.2
    libcurl-7.21.7-5.el5.remi.2
    
    And here is what i got from the second one.


    result :

     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,811
    Likes Received:
    671
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    You are using the third-party REMI repository for YUM. This repo includes some packages that are not normally installed on a standard CentOS system. Are you using this repo for a specific reason? If not, you may want to consider disabling it and proceeding with the cPanel update.

    Thank you.
     
  5. blade3

    blade3 Registered

    Joined:
    Feb 8, 2013
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    [resolved]

    Thanks for your Help Michael,

    i've disabled Remi repository and erase
    libcurl-devel-7.21.7-5.el5.remi.2.x86_64 package

    and all done!!

    thanks alot!
     
    #5 blade3, Feb 8, 2013
    Last edited: Feb 8, 2013
Loading...

Share This Page