The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

update easyapache and all cgi's scripts fail

Discussion in 'EasyApache' started by keycomm, Jul 30, 2003.

  1. keycomm

    keycomm Member

    Joined:
    Apr 2, 2003
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    I have updated with the /scripts/easyapache script twice now and each time after it is finished all CGI scripts on the server fail to run (generic 500 Internal Server Error). Both times I have to reboot to fix the problem. Is it supposed to be like that?

    I did try and restart the services serveral times. I'm on a FreeBSD 4.7 Release box with cPanel 6.4.2 - S85

    Any way to fix this problem without rebooting?

    Thanks.

    cPanel.net Support Ticket Number:

    cPanel.net Support Ticket Number:
     
  2. mickalo

    mickalo Well-Known Member

    Joined:
    Apr 16, 2002
    Messages:
    765
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    N.W. Iowa
    check to see if you have suexec enabled, if so, disable it, then check your scripts. If they start working after you disable suexec, then that's the problem.

    if you have suexec enable and wish to used it, you need to make sure each virtual host in the http.conf has a User and Group assigned, and the scripts are in folder chmoded 0755 like the /cgi-bin and the scripts are chmoded 0755. If you disable suexec this eliminates the need for these settings, but then your running your cgi scripts as "nobody"... which is not very secure, or you can utilize the cgiwrapper within the cpanel, creating a /scgi-bin folder which acts similar to using suexec.

    Hope this may help.

    cPanel.net Support Ticket Number:
     
Loading...

Share This Page