Update error on Provision the current profile in easyapache4

crerem

Member
Apr 7, 2016
7
3
3
romania
cPanel Access Level
Root Administrator
Hi,
I'm trying to upgrade my server to php 7 and after i select all the modules,php version and extension i got this message on review section
Code:
Update Error: Error: ea-apache24-mod_cgi conflicts with ea-apache24-mod_cgid-2.4.18-7.1.x86_64 Error: ea-apache24-mod_cgid conflicts with ea-apache24-mod_cgi-2.4.18-7.1.x86_64 Error: ea-apache24-mod_mpm_worker conflicts with ea-apache24-mod_mpm_prefork-2.4.18-7.1.x86_64 Error: ea-apache24-mod_cgi conflicts with ea-apache24-mod_mpm_worker-2.4.18-7.1.x86_64 Error: ea-apache24-mod_mpm_worker conflicts with ea-apache24-mod_cgi-2.4.18-7.1.x86_64 Error: ea-apache24-mod_mpm_prefork conflicts with ea-apache24-mod_cgid-2.4.18-7.1.x86_64 Error: ea-apache24-mod_mpm_prefork conflicts with ea-apache24-mod_mpm_worker-2.4.18-7.1.x86_64 Error: ea-apache24-mod_cgid conflicts with ea-apache24-mod_mpm_prefork-2.4.18-7.1.x86_64
Here is a screencapture : prntscr.com/ap6fue

I'm not a sys admin so i don't know what to do beyond this point. I asusme i should uninstall some Apache mod but i don't know what mods to keep and how to uninstall.

Can somebody guide me please ?
Thank you
 
  • Like
Reactions: AHMN48

JacobPerkins

Well-Known Member
May 2, 2014
617
97
103
cPanel Access Level
DataCenter Provider
Twitter
Hi,

Either your profile or your selections have conflicts. Here's the breakdowns of CGI's w/MPMs:
Threaded MPM (Event, Worker): mod_cgid
Forked MPM (Prefork): mod_cgi

Ensure that the proper cgi module is selected with your profile.
 
  • Like
Reactions: AHMN48

crerem

Member
Apr 7, 2016
7
3
3
romania
cPanel Access Level
Root Administrator
Hi,
Thank you for the answer but i'm not a sys admin so those don;t make too much sense to me. I just want to have php7. Should i pick another mpm module from the list ? Here is my current selection
prntscr.com/aqsein
Thank you
 
Last edited by a moderator:
  • Like
Reactions: AHMN48

crerem

Member
Apr 7, 2016
7
3
3
romania
cPanel Access Level
Root Administrator
Hi,
Thank you for the help. These are the modules: ea-apache24-mod_cgi,ea-apache24-mod_cgid(installed),ea-apache24-mod_proxy_fcgi,ea-apache24-mod_proxy_scgi.
Here is also a screencapture : prntscr.com/ar9ep8
Thanks
 
  • Like
Reactions: AHMN48

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,215
363
You will need to disable "ea_apache24-mod_cgi" in the build profile you are using.

Thank you.
 
  • Like
Reactions: AHMN48

AHMN48

Member
Jun 15, 2016
8
0
1
USA
cPanel Access Level
Website Owner
You will need to disable "ea_apache24-mod_cgi" in the build profile you are using.

Thank you.
Dear Michael Need Your Help , Stuck in Review when install PHP 7.0 , please check Screenshot
[Removed - Please attach images directly to posts]
 
Last edited by a moderator:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,215
363
Dear Michael Need Your Help , Stuck in Review when install PHP 7.0 , please check Screenshot
[Removed - Please attach images directly to posts]
Hello,

Could you attach the image directly to the post, or paste the error message in CODE tags?

Thank you.
 

WhiteDog

Well-Known Member
Feb 19, 2008
142
6
68
Hello Michael,

I have about the same problem:
Code:
Update Error:
Error: ea-apache24-mod_mpm_worker conflicts with ea-apache24-mod_mpm_prefork-2.4.23-2.2.1.cpanel.x86_64
Error: ea-apache24-mod_cgid conflicts with ea-apache24-mod_mpm_prefork-2.4.23-2.2.1.cpanel.x86_64
Error: ea-apache24-mod_cgi conflicts with ea-apache24-mod_cgid-2.4.23-2.2.1.cpanel.x86_64
Error: ea-apache24-mod_mpm_prefork conflicts with ea-apache24-mod_mpm_worker-2.4.23-2.2.1.cpanel.x86_64
Error: ea-apache24-mod_cgi conflicts with ea-apache24-mod_mpm_worker-2.4.23-2.2.1.cpanel.x86_64
Error: ea-apache24-mod_mpm_prefork conflicts with ea-apache24-mod_cgid-2.4.23-2.2.1.cpanel.x86_64 Error: ea-apache24-mod_cgid conflicts with ea-apache24-mod_cgi-2.4.23-2.2.1.cpanel.x86_64
Error: ea-apache24-mod_mpm_worker conflicts with ea-apache24-mod_cgi-2.4.23-2.2.1.cpanel.x86_64
Under Apache MPM, i have only selected: ea-apache24-mod_mpm_worker
Under Server Modules, i have only selected: ea-apache24-mod_cgid (when searching on cgi)

Should I manually try to remove ea-apache24-mod_mpm_prefork and ea-apache24-mod_cgi first? I am using the worker MPM.

This my Apache Status:
Code:
Server Version: Apache/2.4.23 (cPanel) OpenSSL/1.0.1e-fips mod_bwlimited/1.4
Server MPM: worker
Running cPanel 58.0.13