The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Update error

Discussion in 'General Discussion' started by krismaguire, Jul 23, 2015.

  1. krismaguire

    krismaguire Member

    Joined:
    Jul 18, 2015
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    UK
    cPanel Access Level:
    Root Administrator
    Clicking 'Update System Software' throws out this error:

    Code:
    checkyum version 22.3
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: mirrors.coreix.net
    * updates: mirrors.coreix.net
    Resolving Dependencies
    --> Running transaction check
    ---> Package bind.x86_64 32:9.9.4-18.el7_1.1 will be updated
    ---> Package bind.x86_64 32:9.9.4-18.el7_1.2 will be an update
    ---> Package bind-devel.x86_64 32:9.9.4-18.el7_1.1 will be updated
    ---> Package bind-devel.x86_64 32:9.9.4-18.el7_1.2 will be an update
    ---> Package bind-libs.x86_64 32:9.9.4-18.el7_1.1 will be updated
    ---> Package bind-libs.x86_64 32:9.9.4-18.el7_1.2 will be an update
    ---> Package bind-libs-lite.x86_64 32:9.9.4-18.el7_1.1 will be updated
    ---> Package bind-libs-lite.x86_64 32:9.9.4-18.el7_1.2 will be an update
    ---> Package bind-license.noarch 32:9.9.4-18.el7_1.1 will be updated
    ---> Package bind-license.noarch 32:9.9.4-18.el7_1.2 will be an update
    ---> Package bind-utils.x86_64 32:9.9.4-18.el7_1.1 will be updated
    ---> Package bind-utils.x86_64 32:9.9.4-18.el7_1.2 will be an update
    ---> Package libedit.x86_64 0:3.0-12.20121213cvs.el7 will be updated
    ---> Package libedit.x86_64 0:20090923-3.0_1.el5.rf will be an update
    ---> Package perl-PathTools.x86_64 0:3.40-5.el7 will be updated
    ---> Package perl-PathTools.x86_64 0:3.2701-1.el5.rf will be an update
    --> Processing Dependency: perl(VMS::Filespec) for package: perl-PathTools-3.2701-1.el5.rf.x86_64
    ---> Package perl-Time-Piece.x86_64 0:1.20.1-285.el7 will be updated
    ---> Package perl-Time-Piece.x86_64 1:1.20-1.el5.rf will be an update
    --> Finished Dependency Resolution
    [1;30;41mError: Package: perl-PathTools-3.2701-1.el5.rf.x86_64 (rpmforge)[0m
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest
    [1;30;41mThe system failed to execute yum with the arguments “-y -c /etc/yum.conf update” because of an error: The subprocess “/usr/bin/yum” reported the “EPERM” (1) error when it ended. : Error: Package: perl-PathTools-3.2701-1.el5.rf.x86_64 (rpmforge)[0m
    [1;30;41m           Requires: perl(VMS::Filespec)[0m
    checkyum version 22.3
    Any idea on a fix? I understand it recommend using a particular command but I'd like to know a little more about how this has happened and what causes it.
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    653
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    YUM is your system package manager installed with the OS, so it's not handled by the cPanel software. I notice you are using the RPMForge YUM repo. This is a custom repo. Did you install it manually for a specific purpose?

    Thank you.
     
  3. krismaguire

    krismaguire Member

    Joined:
    Jul 18, 2015
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    UK
    cPanel Access Level:
    Root Administrator
    Hi Michael,

    Thanks for the reply, I managed to skip the broken packages and just update the rest.

    This is a standard install of CPanel on Cent OS 7.1 and I've made no changes to the base install.

    I'm assuming Linode must use a custom image on their images.

    Do you think this could cause issues in the future?
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    653
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    I suggest contacting them to verify if this is the case, and if so, report the error message to their support team so they can address the issue.

    Thank you.
     
  5. John71

    John71 Registered

    Joined:
    Nov 5, 2015
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Romania
    cPanel Access Level:
    Root Administrator
    I have the same error when I try to update CPanel installed on fresh CentOS 7.1:

    [2015-11-05 18:49:02 +0200] [13789] Resolving Dependencies
    [2015-11-05 18:49:02 +0200] [13789] --> Running transaction check
    [2015-11-05 18:49:02 +0200] [13789] ---> Package libedit.x86_64 0:3.0-12.20121213cvs.el7 will be updated
    [2015-11-05 18:49:02 +0200] [13789] ---> Package libedit.x86_64 0:20090923-3.0_1.el5.rf will be an update
    [2015-11-05 18:49:02 +0200] [13789] ---> Package perl-PathTools.x86_64 0:3.40-5.el7 will be updated
    [2015-11-05 18:49:02 +0200] [13789] ---> Package perl-PathTools.x86_64 0:3.2701-1.el5.rf will be an update
    [2015-11-05 18:49:02 +0200] [13789] --> Processing Dependency: perl(VMS::Filespec) for package: perl-PathTools-3.2701-1.el5.rf.x86_64
    [2015-11-05 18:49:02 +0200] [13789] ---> Package perl-Time-Piece.x86_64 0:1.20.1-285.el7 will be updated
    [2015-11-05 18:49:02 +0200] [13789] ---> Package perl-Time-Piece.x86_64 1:1.20-1.el5.rf will be an update
    [2015-11-05 18:49:02 +0200] [13789] --> Finished Dependency Resolution
    [2015-11-05 18:49:02 +0200] [13789] Error: Package: perl-PathTools-3.2701-1.el5.rf.x86_64 (rpmforge)
    [2015-11-05 18:49:02 +0200] [13789] You could try using --skip-broken to work around the problem
    [2015-11-05 18:49:02 +0200] [13789] You could try running: rpm -Va --nofiles --nodigest
    [2015-11-05 18:49:02 +0200] [13789] The system failed to execute yum with the arguments “-y -c /etc/yum.conf update” because of an error: The subprocess “/usr/bin/yum” reported the “EPERM” (1) error when it ended. : Error: Package: perl-PathTools-3.2701-1.el5.rf.x86_64 (rpmforge)
    [2015-11-05 18:49:02 +0200] [13789] Requires: perl(VMS::Filespec)
     
Loading...

Share This Page