rezashamdani

Member
Oct 22, 2015
6
1
3
Indonesia
cPanel Access Level
Root Administrator
Hi,

My current server is on CENTOS 6.6 x86_64 WHM 11.44.1 (build 21)

Previously my update failed due to frontpage extension still detected, and when changing the update preferences from `Never Update` to `Manual Update`, now the output of upcp is like below, please help me to resolve.
Code:
===================================
[email protected] [~]# /scripts/upcp
----------------------------------------------------------------------------------------------------
=> Log opened from cPanel Update (upcp) - Slave (15762) at Sat Apr 20 20:14:51 2019
[20190420.201451]   Detected cron=0 (SSH connection detected)
[20190420.201451]   1% complete
[20190420.201451]   Running Standardized hooks
[20190420.201451]   2% complete
[20190420.201451]   mtime on upcp is 1415979787 (Fri Nov 14 23:43:07 2014)
----------------------------------------------------------------------------------------------------
=> Log opened from /usr/local/cpanel/scripts/updatenow (15764) at Sat Apr 20 20:14:51 2019
[20190420.201451]   Detected version '11.44.3.5' from version file.
[20190420.201451]   Using mirror '203.174.85.202' for host 'httpupdate.cpanel.net'.
[20190420.201452]   Target version set to '11.78.0.21'
[20190420.201452]   Switching to 11.78.0.21 to determine if we can reach that version without failure.
[20190420.201452]   Retrieving and staging /cpanelsync/11.78.0.21/cpanel/scripts/updatenow.static.bz2
[20190420.201452]   Using mirror '203.174.85.202' for host 'httpupdate.cpanel.net'.
[20190420.201452]   Set permissions on /usr/local/cpanel/scripts/updatenow.static-cpanelsync to 0700
=> Log closed Sat Apr 20 20:14:52 2019
[20190420.201452]   17% complete
[20190420.201452] E Running `/usr/local/cpanel/scripts/updatenow --upcp --log=/var/cpanel/updatelogs/update.1555762491.log` failed, exited with code 2 (signal = 0)
=> Log closed Sat Apr 20 20:14:52 2019
[email protected] [~]# cat /var/cpanel/updatelogs/update.1555762491.log
----------------------------------------------------------------------------------------------------
=> Log opened from cPanel Update (upcp) - Slave (15762) at Sat Apr 20 20:14:51 2019
[20190420.201451]   Detected cron=0 (SSH connection detected)
[20190420.201451]   1% complete
[20190420.201451]   Running Standardized hooks
[20190420.201451]   2% complete
[20190420.201451]   mtime on upcp is 1415979787 (Fri Nov 14 23:43:07 2014)
----------------------------------------------------------------------------------------------------
=> Log opened from /usr/local/cpanel/scripts/updatenow (15764) at Sat Apr 20 20:14:51 2019
[20190420.201451]   Detected version '11.44.3.5' from version file.
[20190420.201451]   Using mirror '203.174.85.202' for host 'httpupdate.cpanel.net'.
[20190420.201452]   Target version set to '11.78.0.21'
[20190420.201452]   Switching to 11.78.0.21 to determine if we can reach that version without failure.
[20190420.201452]   Retrieving and staging /cpanelsync/11.78.0.21/cpanel/scripts/updatenow.static.bz2
[20190420.201452]   Using mirror '203.174.85.202' for host 'httpupdate.cpanel.net'.
[20190420.201452]   Set permissions on /usr/local/cpanel/scripts/updatenow.static-cpanelsync to 0700
=> Log closed Sat Apr 20 20:14:52 2019
[20190420.201452]   17% complete
[20190420.201452] E Running `/usr/local/cpanel/scripts/updatenow --upcp --log=/var/cpanel/updatelogs/update.1555762491.log` failed, exited with code 2 (signal = 0)
=> Log closed Sat Apr 20 20:14:52 2019
 
Last edited by a moderator:

GOT

Get Proactive!
PartnerNOC
Apr 8, 2003
1,755
316
363
Chesapeake, VA
cPanel Access Level
DataCenter Provider
11.44 is REALLY old. The logs are not giving you any real indication as to the cause of the failure. However, I see you say you are on Centos 6.6 which might mean yum is not working. I would first try a yum update and see if that runs correctly and gets the system updated. If there are errors, those should be resolved until you get Centos up to 6.10.

You should also reboot once you are done with a successful yum update. Then try the cpanel update again.
 

rezashamdani

Member
Oct 22, 2015
6
1
3
Indonesia
cPanel Access Level
Root Administrator
hi, thanks for replying.

i'm already did yum update and reboot earlier.
Code:
Last login: Sat Apr 20 20:14:31 2019 from 140.213.20.191
[email protected] [~]# yum update
Loaded plugins: fastestmirror, security
Setting up Update Process
Loading mirror speeds from cached hostfile
 * base: mirror.0x.sg
 * extras: mirror.0x.sg
 * updates: mirror.0x.sg
base                                                                                                                                                          | 3.7 kB     00:00
extras                                                                                                                                                        | 3.4 kB     00:00
updates                                                                                                                                                       | 3.4 kB     00:00
No Packages marked for Update
 

GOT

Get Proactive!
PartnerNOC
Apr 8, 2003
1,755
316
363
Chesapeake, VA
cPanel Access Level
DataCenter Provider
Yes, but, you said you were at 6.6 and if yum was working you would be at 6.10 so I would suggest trying yum clean all and then yum update.
 

rezashamdani

Member
Oct 22, 2015
6
1
3
Indonesia
cPanel Access Level
Root Administrator
hi @GOT, here is your suggestion result
Code:
[email protected] [~]# yum clean all
Loaded plugins: fastestmirror, security
Cleaning repos: base extras updates
Cleaning up Everything
Cleaning up list of fastest mirrors
[email protected] [~]# yum update
Loaded plugins: fastestmirror, security
Setting up Update Process
Determining fastest mirrors
 * base: mirror.vastspace.net
 * extras: mirror.vastspace.net
 * updates: mirror.vastspace.net
base                                                                                                                                                          | 3.7 kB     00:00
base/primary_db                                                                                                                                               | 4.7 MB     00:00
extras                                                                                                                                                        | 3.4 kB     00:00
extras/primary_db                                                                                                                                             |  29 kB     00:00
updates                                                                                                                                                       | 3.4 kB     00:00
updates/primary_db                                                                                                                                            | 3.7 MB     00:00
No Packages marked for Update
Along with the suggestions provided by @GOT is anything noted in the cPanel error logs?
can you tell me where the logs you refer to?
 
Last edited by a moderator:

rezashamdani

Member
Oct 22, 2015
6
1
3
Indonesia
cPanel Access Level
Root Administrator
here is the error_log
Code:
[email protected] [~]# tail -f /usr/local/cpanel/logs/error_log
[2019-04-25 23:08:04 +0800] info [checkccompiler] /root/.cpanel/datastore/Cpanel::Sys::Compiler::test_compile_gcc
[2019-04-25 23:09:25 +0800] info [check_cpanel_rpms] rpmcheck Notification => [email protected] via EMAIL [level => 3]
[2019-04-25 23:09:27 +0800] info [cleanquotas] Checking for orphaned quotas...
[2019-04-25 23:09:27 +0800] info [cleanquotas] Done.
[2019-04-25 23:09:34 +0800] info [email_archive_maintenance] Email archiving is disabled per Tweak Settings.
[2019-04-25 23:55:12 +0800] info [gather-update-logs] file /var/cpanel/update_blocks.config doesn't exist
[2019-04-25 23:55:12 +0800] info [gather-update-logs] file /etc/cpsources.conf doesn't exist
[2019-04-25 23:55:15 +0800] info [gather-update-logs] Cannot send file /usr/local/cpanel/logs/update_analysis/2019-04-25T15:54:37Z.tar.gz to updatelogdrop.cpanel.net.
[2019-04-25 23:55:15 +0800] info [gather-update-logs] Failed to send data to cPanel
[2019-04-26 02:00:02 +0800] info [backup] Backup Not Enabled (This can be adjusted in WHM => Backup => Backup Configuration)
[2019-04-26 12:37:06 +0800] info [upcp] upcp Notification => [email protected] via EMAIL [level => 1]
[2019-04-26 12:37:44 +0800] info [upcp] upcp Notification => [email protected] via EMAIL [level => 1]
that last 2 is the result of today action which is running `/scripts/upcp` twice.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,295
1,272
313
Houston
Hi @rezashamdani

Thanks for providing that, nothing that looks especially informative here, unfortunately.
Can you please open a ticket using the link in my signature? Once open please reply with the Ticket ID here so that we can update this thread with the resolution once the ticket is resolved.


Thanks!
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,295
1,272
313
Houston
Hello @rezashamdani


I checked in on this ticket and it looks like our analyst was able to get update started successfully as well as help you get from v11.44 to to v11.76 of cPanel. You will need to migrate from EA3 -> EA4 before you'll be able to go any farther and we've offered to assist with that process as well.


Thanks!