SOLVED Update failure in upcp script

Xenofon V

Member
Nov 26, 2016
8
0
1
Greece
cPanel Access Level
Root Administrator
Hello, I installed cPanel for the first time on an ec2 instance a few months ago and everything was going perfectly. A few days now I get this error " cPanel & WHM update failure in upcp script " and cPanel can't update.

I give you the log below, I am pretty new to this so I would appreciate it if you could be descriptive!

Thankw!
 

Attachments

SysSachin

Well-Known Member
Aug 23, 2015
604
48
28
India
cPanel Access Level
Root Administrator
Twitter
Hello,
Try to run below command on the server.
Code:
yum update
Once yum update successfully then update cPanel forcefully.
Code:
/scripts/upcp --force
 
Last edited:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,236
463
Hello,

It looks like your attachment isn't loading. Could you post the specific error message from the update logs in CODE tags? Keep in mind we only support Amazon Linux on the official cPanel & WHM AMI. It's available at:

AWS Marketplace: cPanel & WHM: The Hosting Platform of Choice

Once installed, you can then update cPanel to version of your preference.

Thank you.
 

Xenofon V

Member
Nov 26, 2016
8
0
1
Greece
cPanel Access Level
Root Administrator
Hello again, here is the code from yesterday's try to upgrade.

Code:
----------------------------------------------------------------------------------------------------
=> Log opened from cPanel Update (upcp) - Slave (30189) at Thu Dec  1 00:49:01 2016
[2016-12-01 00:49:01 +0000]   Detected cron=1 (cron mode set from command line)
[2016-12-01 00:49:01 +0000]   1% complete
[2016-12-01 00:49:01 +0000]   Running Standardized hooks
[2016-12-01 00:49:01 +0000]   2% complete
[2016-12-01 00:49:01 +0000]   mtime on upcp is 1470185444 (Wed Aug  3 00:50:44 2016)
----------------------------------------------------------------------------------------------------
=> Log opened from /usr/local/cpanel/scripts/updatenow (30193) at Thu Dec  1 00:49:02 2016
[2016-12-01 00:49:02 +0000]   Detected version '11.58.0.37' from version file.
[2016-12-01 00:49:02 +0000]   Running version '11.58.0.37' of updatenow.
[2016-12-01 00:49:02 +0000]   Retrieved public key from vendor: cpanel, category: development, url: https://securedownloads.cpanel.net/cPanelDevelopmentKey.asc
[2016-12-01 00:49:03 +0000]   Retrieved public key from vendor: cpanel, category: release, url: https://securedownloads.cpanel.net/cPanelPublicKey.asc
[2016-12-01 00:49:03 +0000]   Using mirror '185.15.22.168' for host 'httpupdate.cpanel.net'.
[2016-12-01 00:49:03 +0000]   Successfully verified signature for cpanel (key types: release).
[2016-12-01 00:49:03 +0000]   Target version set to '11.60.0.26'
[2016-12-01 00:49:03 +0000]   Switching to 11.60.0.26 to determine if we can reach that version without failure.
[2016-12-01 00:49:03 +0000]   Retrieving and staging /cpanelsync/11.60.0.26/cpanel/scripts/updatenow.static.bz2
[2016-12-01 00:49:03 +0000]   Using mirror '185.15.22.168' for host 'httpupdate.cpanel.net'.
[2016-12-01 00:49:04 +0000]   Successfully verified signature for cpanel (key types: release).
[2016-12-01 00:49:04 +0000]   Set permissions on /usr/local/cpanel/scripts/updatenow.static-cpanelsync to 0700
[2016-12-01 00:49:04 +0000]   Become an updatenow.static for version: 11.60.0.26
=> Log closed Thu Dec  1 00:49:04 2016
----------------------------------------------------------------------------------------------------
=> Log opened from /usr/local/cpanel/scripts/updatenow.static-cpanelsync (30193) at Thu Dec  1 00:49:05 2016
[2016-12-01 00:49:05 +0000]   Detected version '11.58.0.37' from version file.
[2016-12-01 00:49:05 +0000]   Running version '11.60.0.26' of updatenow.
[2016-12-01 00:49:05 +0000]   Using mirror '185.15.22.168' for host 'httpupdate.cpanel.net'.
[2016-12-01 00:49:05 +0000]   Successfully verified signature for cpanel (key types: release).
[2016-12-01 00:49:05 +0000]   Target version set to '11.60.0.26'
[2016-12-01 00:49:05 +0000]   Checking license
[2016-12-01 00:49:05 +0000]   License file check complete
[2016-12-01 00:49:05 +0000]   Checking that the RPM DB is OK...
[2016-12-01 00:49:05 +0000]   glibc-2.17-106.el7_2.6.x86_64
[2016-12-01 00:49:05 +0000]   OK: RPM DB is responding to queries
[2016-12-01 00:49:05 +0000]   Testing if rpm_is_working RPM is installed
[2016-12-01 00:49:05 +0000]   package rpm_is_working is not installed
[2016-12-01 00:49:05 +0000]   Testing if it's possible to install a simple RPM
[2016-12-01 00:49:05 +0000]   Preparing...                          ########################################
[2016-12-01 00:49:05 +0000]   Updating / installing...
[2016-12-01 00:49:05 +0000]   rpm_is_working-1.0-0                  ########################################
[2016-12-01 00:49:05 +0000]   Switching to version '11.60.0.26' of updatenow to perform sync.
[2016-12-01 00:49:05 +0000]   checkyum version 22.3
[2016-12-01 00:49:06 +0000]   checkyum version 22.3
[2016-12-01 00:49:06 +0000]   Loaded plugins: fastestmirror
[2016-12-01 00:49:07 +0000]   Loading mirror speeds from cached hostfile
[2016-12-01 00:49:07 +0000]   No package ImageMagick available.
[2016-12-01 00:49:07 +0000]   No package boost-program-options available.
[2016-12-01 00:49:07 +0000]   No package boost-serialization available.
[2016-12-01 00:49:07 +0000] E Error: Nothing to do
[2016-12-01 00:49:07 +0000] E (XID yt8rhz) The system failed to execute yum with the arguments “-y -c /etc/yum.conf install ImageMagick boost-program-options boost-serialization” because of an error: The “/usr/bin/yum” command (process 30310) reported error number 1 when it ended. : Error: Nothing to do
[2016-12-01 00:49:07 +0000]   checkyum version 22.3
[2016-12-01 00:49:08 +0000] E Sysup: Needed system RPMs were not installed: ImageMagick, boost-program-options, boost-serialization
[2016-12-01 00:49:08 +0000] ***** FATAL: Cannot proceed. Needed system RPMs were not installed.
[2016-12-01 00:49:08 +0000]   The Administrator will be notified to review this output when this script completes
=> Log closed Thu Dec  1 00:49:08 2016
[2016-12-01 00:49:09 +0000]   17% complete
[2016-12-01 00:49:09 +0000] E Running `/usr/local/cpanel/scripts/updatenow --upcp --log=/var/cpanel/updatelogs/update.1480553341.log` failed, exited with code 18 (signal = 0)
=> Log closed Thu Dec  1 00:49:09 2016
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,236
463
Hello,

I noticed a couple of recent support requests where this issue related to a non-working mirror on the initial cPanel update request, and later completed successfully. Try running the following commands and let us know if you notice any issues:

Code:
yum clean all
yum update
Thank you.
 

Xenofon V

Member
Nov 26, 2016
8
0
1
Greece
cPanel Access Level
Root Administrator
Hello again, I run these commands and now i get this

Code:
----------------------------------------------------------------------------------------------------
=> Log opened from cPanel Update (upcp) - Slave (9798) at Sat Dec  3 09:53:26 2016
[2016-12-03 09:53:26 +0000]   Detected cron=0 (--force passed on command line)
[2016-12-03 09:53:26 +0000]   1% complete
[2016-12-03 09:53:26 +0000]   Running Standardized hooks
[2016-12-03 09:53:26 +0000]   2% complete
[2016-12-03 09:53:26 +0000]   mtime on upcp is 1470185444 (Wed Aug  3 00:50:44 2016)
----------------------------------------------------------------------------------------------------
=> Log opened from /usr/local/cpanel/scripts/updatenow (9806) at Sat Dec  3 09:53:26 2016
[2016-12-03 09:53:26 +0000]   Detected version '11.58.0.37' from version file.
[2016-12-03 09:53:26 +0000]   Running version '11.58.0.37' of updatenow.
[2016-12-03 09:53:26 +0000]   --force passed on command line. Upgrade will disregard update config settings.
[2016-12-03 09:53:26 +0000]   Using mirror '185.69.232.245' for host 'httpupdate.cpanel.net'.
[2016-12-03 09:53:27 +0000]   Successfully verified signature for cpanel (key types: release).
[2016-12-03 09:53:27 +0000]   Target version set to '11.60.0.26'
[2016-12-03 09:53:27 +0000]   Switching to 11.60.0.26 to determine if we can reach that version without failure.
[2016-12-03 09:53:27 +0000]   Retrieving and staging /cpanelsync/11.60.0.26/cpanel/scripts/updatenow.static.bz2
[2016-12-03 09:53:27 +0000]   Using mirror '185.69.232.245' for host 'httpupdate.cpanel.net'.
[2016-12-03 09:53:28 +0000]   Successfully verified signature for cpanel (key types: release).
[2016-12-03 09:53:28 +0000]   Set permissions on /usr/local/cpanel/scripts/updatenow.static-cpanelsync to 0700
[2016-12-03 09:53:28 +0000]   Become an updatenow.static for version: 11.60.0.26
=> Log closed Sat Dec  3 09:53:28 2016
----------------------------------------------------------------------------------------------------
=> Log opened from /usr/local/cpanel/scripts/updatenow.static-cpanelsync (9806) at Sat Dec  3 09:53:31 2016
[2016-12-03 09:53:31 +0000]   Detected version '11.58.0.37' from version file.
[2016-12-03 09:53:31 +0000]   Running version '11.60.0.26' of updatenow.
[2016-12-03 09:53:31 +0000]   --force passed on command line. Upgrade will disregard update config settings.
[2016-12-03 09:53:31 +0000]   Using mirror '185.69.232.245' for host 'httpupdate.cpanel.net'.
[2016-12-03 09:53:31 +0000]   Successfully verified signature for cpanel (key types: release).
[2016-12-03 09:53:31 +0000]   Target version set to '11.60.0.26'
[2016-12-03 09:53:31 +0000]   Checking license
[2016-12-03 09:53:32 +0000]   License file check complete
[2016-12-03 09:53:32 +0000]   Checking that the RPM DB is OK...
[2016-12-03 09:53:32 +0000]   glibc-2.17-106.el7_2.6.x86_64
[2016-12-03 09:53:32 +0000]   OK: RPM DB is responding to queries
[2016-12-03 09:53:32 +0000]   Testing if rpm_is_working RPM is installed
[2016-12-03 09:53:32 +0000]   package rpm_is_working is not installed
[2016-12-03 09:53:32 +0000]   Testing if it's possible to install a simple RPM
[2016-12-03 09:53:32 +0000]   Preparing...                          ########################################
[2016-12-03 09:53:32 +0000]   Updating / installing...
[2016-12-03 09:53:32 +0000]   rpm_is_working-1.0-0                  ########################################
[2016-12-03 09:53:32 +0000]   Switching to version '11.60.0.26' of updatenow to perform sync.
[2016-12-03 09:53:32 +0000]   checkyum version 22.3
[2016-12-03 09:53:34 +0000]   checkyum version 22.3
[2016-12-03 09:53:35 +0000]   Loaded plugins: fastestmirror
[2016-12-03 09:53:35 +0000]   Loading mirror speeds from cached hostfile
[2016-12-03 09:53:35 +0000]   No package boost-program-options available.
[2016-12-03 09:53:36 +0000]   No package boost-serialization available.
[2016-12-03 09:53:36 +0000] E Error: Nothing to do
[2016-12-03 09:53:36 +0000] E (XID 8tgpa2) The system failed to execute yum with the arguments “-y -c /etc/yum.conf install ImageMagick boost-program-options boost-serialization” because of an error: The “/usr/bin/yum” command (process 9940) reported error number 1 when it ended. : Error: Nothing to do
[2016-12-03 09:53:36 +0000]   checkyum version 22.3
[2016-12-03 09:53:37 +0000] E Sysup: Needed system RPMs were not installed: ImageMagick, boost-program-options, boost-serialization
[2016-12-03 09:53:37 +0000] ***** FATAL: Cannot proceed. Needed system RPMs were not installed.
[2016-12-03 09:53:37 +0000]   The Administrator will be notified to review this output when this script completes
=> Log closed Sat Dec  3 09:53:37 2016
[2016-12-03 09:53:37 +0000]   17% complete
[2016-12-03 09:53:37 +0000] E Running `/usr/local/cpanel/scripts/updatenow --upcp --log=/var/cpanel/updatelogs/update.1480758806.log --force` failed, exited with code 18 (signal = 0)
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,236
463
Everything looks good..

- Removed -
Hello,

I'm happy to see the issue is now resolved. Could you verify the solution that addressed the issue?

Thanks!
 

Xenofon V

Member
Nov 26, 2016
8
0
1
Greece
cPanel Access Level
Root Administrator
Well I did it updating automatically and when I do try it manually i try from WHM panel. I have CentOS installed. The only commands I tried are the ones I found on the answers here.

yum clean all
yum update
/scripts/upcp --force
 

Infopro

Well-Known Member
May 20, 2003
17,085
521
613
Pennsylvania
cPanel Access Level
Root Administrator
Twitter
I'm wondering why this is in your update log:
Code:
The system failed to execute yum with the arguments “-y -c /etc/yum.conf install ImageMagick boost-program-options boost-serialization”
Please feel free to open a ticket to cPanel Technical Support about this issue if you like.
 
Thread starter Similar threads Forum Replies Date
U Hyperscalers 2