Update failure in upcp script

tomdchi

Well-Known Member
Feb 24, 2008
142
4
68
Atlanta, GA
cPanel Access Level
DataCenter Provider
Getting this in the logs:

Code:
[2021-12-19 03:17:08 -0500]   Processing: Running rpmup (yum -y update)
[2021-12-19 03:17:08 -0500]    - Processing command `/usr/local/cpanel/scripts/rpmup`
[2021-12-19 03:17:08 -0500]      [/usr/local/cpanel/scripts/rpmup] checkyum version 22.3  (excludes: bind-chroot kernel)
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup] Loaded plugins: fastestmirror, universal-hooks
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup] Loading mirror speeds from cached hostfile
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup]  * EA4: 63.247.64.58
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup]  * cpanel-addons-production-feed: 63.247.64.58
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup]  * cpanel-plugins: 63.247.64.58
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup]  * base: download.cf.centos.org
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup]  * epel: d2lzkl7pfhq30w.cloudfront.net
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup]  * extras: download.cf.centos.org
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup]  * updates: download.cf.centos.org
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup] Resolving Dependencies
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup] --> Running transaction check
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup] ---> Package ai-bolit.x86_64 1:31.0.3-1.el7 will be updated
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup] ---> Package ai-bolit.x86_64 1:31.3.3-1.el7 will be an update
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup] --> Processing Dependency: alt-php-hyperscan >= 1:5.4.0-3 for package: 1:ai-bolit-31.3.3-1.el7.x86_64
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup] ---> Package imunify-antivirus.noarch 0:5.10.2-1 will be updated
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup] ---> Package imunify-antivirus.noarch 0:6.1.2-1 will be an update
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup] --> Processing Dependency: alt-python38 >= 3.8.6-9 for package: imunify-antivirus-6.1.2-1.noarch
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup] --> Processing Dependency: alt-python38-async-lru >= 1.0.2 for package: imunify-antivirus-6.1.2-1.noarch
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup] --> Processing Dependency: app-version-detector >= 1:21.0908-1 for package: imunify-antivirus-6.1.2-1.noarch
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup] ---> Package imunify-antivirus-cpanel.noarch 0:5.10.2-1 will be updated
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup] ---> Package imunify-antivirus-cpanel.noarch 0:6.1.2-1 will be an update
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup] ---> Package ncpa.x86_64 0:2.3.1-1.el7 will be updated
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup] ---> Package ncpa.x86_64 0:2.4.0-1.el7 will be an update
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup] --> Running transaction check
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup] ---> Package ai-bolit.x86_64 1:31.3.3-1.el7 will be an update
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup] --> Processing Dependency: alt-php-hyperscan >= 1:5.4.0-3 for package: 1:ai-bolit-31.3.3-1.el7.x86_64
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup] ---> Package alt-python38-async-lru.noarch 0:1.0.2-1.el7 will be installed
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup] ---> Package imunify-antivirus.noarch 0:6.1.2-1 will be an update
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup] --> Processing Dependency: alt-python38 >= 3.8.6-9 for package: imunify-antivirus-6.1.2-1.noarch
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup] --> Processing Dependency: app-version-detector >= 1:21.0908-1 for package: imunify-antivirus-6.1.2-1.noarch
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup] --> Finished Dependency Resolution
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup] Error: Package: imunify-antivirus-6.1.2-1.noarch (imunify360-rollout-1)
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup]            Requires: app-version-detector >= 1:21.0908-1
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup]            Installed: 1:app-version-detector-21.0421-1.el7.x86_64 (@imunify360)
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup]                app-version-detector = 1:21.0421-1.el7
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup]  You could try using --skip-broken to work around the problem
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup] Error: Package: 1:ai-bolit-31.3.3-1.el7.x86_64 (imunify360-rollout-1)
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup]            Requires: alt-php-hyperscan >= 1:5.4.0-3
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup]            Installed: 1:alt-php-hyperscan-5.4.0-1.el7.x86_64 (@imunify360)
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup]                alt-php-hyperscan = 1:5.4.0-1.el7
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup] Error: Package: imunify-antivirus-6.1.2-1.noarch (imunify360-rollout-1)
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup]            Requires: alt-python38 >= 3.8.6-9
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup]            Installed: alt-python38-3.8.6-5.el7.x86_64 (@imunify360-rollout-1)
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup]                alt-python38 = 3.8.6-5.el7
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup]  You could try running: rpm -Va --nofiles --nodigest
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup] (XID akwtxv) “/usr/bin/yum” reported error code “1” when it ended:
[2021-12-19 03:17:20 -0500]      [/usr/local/cpanel/scripts/rpmup] checkyum version 22.3  (excludes: bind-chroot)
[2021-12-19 03:17:20 -0500] E    [/usr/local/cpanel/scripts/rpmup] The “/usr/local/cpanel/scripts/rpmup” command (process 20278) reported error number 1 when it ended.
[2021-12-19 03:17:20 -0500]   The Administrator will be notified to review this output when this script completes
[2021-12-19 03:17:20 -0500]    - Finished command `/usr/local/cpanel/scripts/rpmup` in 11.948 seconds
I have already tried yum clean all && yum makecache. What should I do to fix this?
 

andrew.n

Well-Known Member
Jun 9, 2020
875
325
63
EU
cPanel Access Level
Root Administrator
hm I would probably uninstall ImmunifyAV:

yum remove imunify-antivirus

then proceed with the cPanel updates:

/scripts/upcp

and install ImmunifyAV again:

yum install imunify-antivirus
 
  • Like
Reactions: cPanelAnthony