The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Update from 11.34 to 11.36 fails Mysql conflict

Discussion in 'General Discussion' started by kernow, Jan 29, 2013.

  1. kernow

    kernow Well-Known Member

    Joined:
    Jul 23, 2004
    Messages:
    865
    Likes Received:
    9
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    The update to 11.36 from 11.34 current failed to complete due to Mysql conflict. End of log below:
    Note Currently installed: 5.5.28
     
    #1 kernow, Jan 29, 2013
    Last edited: Jan 29, 2013
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Could you submit a support ticket so we can take a closer look?

    Submit A Ticket

    Please provide us with the ticket number so we can update this thread.

    Thank you.
     
  3. kernow

    kernow Well-Known Member

    Joined:
    Jul 23, 2004
    Messages:
    865
    Likes Received:
    9
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Request id is: 3690407
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    This happened because MySQL updates were disabled due to the use of some custom MySQL RPMs (Cloud Linux in this case). MySQL updates were disabled with the existence of the following file:

    Code:
    /etc/mysqlupdisable
    The issue was that MySQL updates were not also disabled in /etc/cpupdate.conf:

    Code:
    MYSQLUP=inherit
    RPMUP=daily
    SYSUP=daily
    The cPanel update can proceed when "MYSQLUP=never" is configured in /etc/cpupdate.conf. This can also be changed in "WHM Home » Server Configuration » Update Preferences" prior to updating to version 11.36. We have an internal case open to address "upcp" detecting the presence of /etc/mysqlupdisable. The case number is 63298.

    Thank you.
     
  5. vectro

    vectro Member

    Joined:
    Sep 2, 2008
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    This fix worked for me. I added "MYSQLUP=never" to /etc/cpupdate.conf and it resolved the same error as the OP.
     
Loading...

Share This Page