Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Update mysql 5.1 to 5.5

Discussion in 'Database Discussion' started by davidcm, Oct 21, 2015.

  1. davidcm

    davidcm Registered

    Joined:
    Oct 21, 2015
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    madrid
    cPanel Access Level:
    Root Administrator
    Hello,

    I received the next message. It's ok, but I have many web in WHM, around 20, and I don't know if I should to upgrade because maybe i will get a lot of problem in my webs page (php, wordpress, prestashop, ruby).

    What Do you think about that?

    Thank you a lot!

    The installation of “MySQL” is out of date on the server.

    The following application on the server should be updated as soon as possible.

    Application Currently Recommended How to Upgrade
    MySQL 5.1 5.5 For instructions on how to upgrade “MySQL”, visit MySQL/MariaDB Upgrade - Documentation - cPanel Documentation
    This notice is the result of a request from “scripts/maintenance”.
    This notice was generated “Wednesday, October 21, 2015 9:52:55 AM UTC”.

     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,344
    Likes Received:
    1,852
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello :)

    Most users report few problems when upgrading to MySQL 5.5. However, MySQL offers the following document that allows you to see potential issues with your scripts when upgrading from earlier versions:

    MySQL :: MySQL 5.5 Reference Manual :: 2.11.1.1 Changes Affecting Upgrades to 5.5

    Essentially, as long as your scripts are updated to their latest versions, you are not likely to encounter any issues.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. extremelady

    extremelady Registered

    Joined:
    Nov 2, 2015
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Philippines
    cPanel Access Level:
    DataCenter Provider
    Is there would be any issue if your server stay with MySQL 5.1? or better to upgrade to 5.5 or 5.6?
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,344
    Likes Received:
    1,852
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello :)

    MySQL 5.1 is end-of-life and thus no longer supported. I suggest updating as soon as possible to avoid potential issues with newer versions of cPanel.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice