Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Update php libxml

Discussion in 'EasyApache' started by Milan Madar, Aug 5, 2017.

  1. Milan Madar

    Milan Madar Registered

    Joined:
    Nov 9, 2016
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Germany
    cPanel Access Level:
    Root Administrator
    Hi,

    I would like to update the libxml for PHP. How can I do that? Or, how can I tell what libxml version will I get if I rebuild the whole configuration with EasyApache4? See the system details below.

    Thank you
    Code:
    --------
    
    CENTOS 6.9 x86_64 kvm
    cPanel & WHM 64.0 (build 36)
    EasyApache4
    
    php -v
    ea-php-cli Copyright 2017 cPanel, Inc.
    PHP 5.6.31 (cli) (built: Jul 18 2017 00:58:22)
    Copyright (c) 1997-2016 The PHP Group
    Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
        with Xdebug v2.4.1, Copyright (c) 2002-2016, by Derick Rethans
    
    php -i | grep libxml
    libxml Version => 2.7.6
    libxml
    libxml2 Version => 2.7.6
    libxslt compiled against libxml Version => 2.9.4
    
    yum list installed libxml*
    Installed Packages
    libxml2.x86_64                              2.9.4-2.0.cf.rhel6                         @Example.org
    libxml2-devel.x86_64                        2.9.4-2.0.cf.rhel6                         @Example.org
     
    #1 Milan Madar, Aug 5, 2017
    Last edited by a moderator: Aug 5, 2017
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,419
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    EasyApache 4 uses the OS-provided version of of libxml at this time. We briefly switched to a version provided with EasyApache, but the change was reverted after some unexpected issues (see this thread). If you have manually upgraded libxml on CentOS 6, try reinstalling the EasyApache 4 PHP RPM with a command like this (for PHP 7.0):

    Code:
    yum reinstall ea-php70
    Thank you.
     
  3. Milan Madar

    Milan Madar Registered

    Joined:
    Nov 9, 2016
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Germany
    cPanel Access Level:
    Root Administrator
    Thank you for the reply.

    I did not upgrade OS libxml manually.

    The goal is to upgrade php-libxml to 2.7.8 or above (that was not clear in OP).

    Do you mean I happen to have that "briefly switched" EasyApache version, but if I just yum-reinstall the ea-php* package now then php will get the OS provided libxml version?

    If so, then which package do I need to reinstall?

    Code:
    Installed Packages
    ea-php-cli.x86_64                                      0.2.0-6.6.1.cpanel                       @EA4
    ea-php-cli-lsphp.x86_64                                0.2.0-6.6.1.cpanel                       @EA4
    ea-php56.x86_64                                        5.6.31-1.1.1.cpanel                      @EA4
    ea-php56-libc-client.x86_64                            2007f-9.9.4.cpanel                       @EA4
    ea-php56-libc-client-devel.x86_64                      2007f-9.9.4.cpanel                       @EA4
    ea-php56-libc-client-static.x86_64                     2007f-9.9.4.cpanel                       @EA4
    ea-php56-pear.noarch                                   1.10.1-7.7.27.cpanel                     @EA4
    ea-php56-php-bcmath.x86_64                             5.6.31-2.2.2.cpanel                      @EA4
    ea-php56-php-calendar.x86_64                           5.6.31-2.2.2.cpanel                      @EA4
    ea-php56-php-cli.x86_64                                5.6.31-2.2.2.cpanel                      @EA4
    ea-php56-php-common.x86_64                             5.6.31-2.2.2.cpanel                      @EA4
    ea-php56-php-curl.x86_64                               5.6.31-2.2.2.cpanel                      @EA4
    ea-php56-php-dba.x86_64                                5.6.31-2.2.2.cpanel                      @EA4
    ea-php56-php-devel.x86_64                              5.6.31-2.2.2.cpanel                      @EA4
    ea-php56-php-exif.x86_64                               5.6.31-2.2.2.cpanel                      @EA4
    ea-php56-php-fileinfo.x86_64                           5.6.31-2.2.2.cpanel                      @EA4
    ea-php56-php-fpm.x86_64                                5.6.31-2.2.2.cpanel                      @EA4
    ea-php56-php-ftp.x86_64                                5.6.31-2.2.2.cpanel                      @EA4
    ea-php56-php-gd.x86_64                                 5.6.31-2.2.2.cpanel                      @EA4
    ea-php56-php-iconv.x86_64                              5.6.31-2.2.2.cpanel                      @EA4
    ea-php56-php-imap.x86_64                               5.6.31-2.2.2.cpanel                      @EA4
    ea-php56-php-intl.x86_64                               5.6.31-2.2.2.cpanel                      @EA4
    ea-php56-php-litespeed.x86_64                          5.6.31-2.2.2.cpanel                      @EA4
    ea-php56-php-mbstring.x86_64                           5.6.31-2.2.2.cpanel                      @EA4
    ea-php56-php-mcrypt.x86_64                             5.6.31-2.2.2.cpanel                      @EA4
    ea-php56-php-mysqlnd.x86_64                            5.6.31-2.2.2.cpanel                      @EA4
    ea-php56-php-pdo.x86_64                                5.6.31-2.2.2.cpanel                      @EA4
    ea-php56-php-posix.x86_64                              5.6.31-2.2.2.cpanel                      @EA4
    ea-php56-php-process.x86_64                            5.6.31-2.2.2.cpanel                      @EA4
    ea-php56-php-sockets.x86_64                            5.6.31-2.2.2.cpanel                      @EA4
    ea-php56-php-xml.x86_64                                5.6.31-2.2.2.cpanel                      @EA4
    ea-php56-runtime.x86_64                                5.6.31-1.1.1.cpanel                      @EA4
    
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,419
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    No, if you have ran "yum update" in recent weeks, then the change would have been reverted with the EA4 release on 2017-05-17:

    EasyApache 4 Change Log - EasyApache 4 - cPanel Documentation

    EasyApache 4 will use OS provided libraries for libxml2. Thus, if you wanted to use version 2.7.8, then you'd need to manually install that version of libxml2 in your OS. You can use the following command to see which RPM is currently installed:

    Code:
    rpm -qa|grep libxml
    Thank you.
     
  5. Milan Madar

    Milan Madar Registered

    Joined:
    Nov 9, 2016
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Germany
    cPanel Access Level:
    Root Administrator
    It seems thats not happening in my case

    Code:
    [root@a1 ~]# rpm -qa|grep libxml
    libxml2-2.9.4-4.0.cf.rhel6.x86_64
    python-libxml2-2.9.4-4.0.cf.rhel6.x86_64
    cpanel-perl-524-libxml-perl-0.08-1.cp1162.x86_64
    libxml2-devel-2.9.4-4.0.cf.rhel6.x86_64
    
    php -i | grep libxml
    libxml Version => 2.7.6
    libxml
    libxml2 Version => 2.7.6
    
    phpinfo also says 2.7.6

    So my OS is 2.9, php is 2.7.

    How can I make php (built with EA4) also be 2.9?
     
    #5 Milan Madar, Aug 10, 2017
    Last edited by a moderator: Aug 10, 2017
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,419
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you open a support ticket using the link in my signature so we can take a closer look to see why the versions are not matching?

    Thank you.
     
  7. salvazo

    salvazo Member

    Joined:
    May 2, 2011
    Messages:
    14
    Likes Received:
    1
    Trophy Points:
    53
    Hi, I need to upgrade to libxml 2.7.7 or above and it's not clear how to acomplish this. I can't find more information about this particular matter on the forums. My PHP Version is 7.0.22. Thanks!
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,419
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    EasyApache 4 will use OS provided libraries for libxml2. Thus, if you wanted to use version that's newer than what your OS currently provides, you'd need to manually install that version of libxml2 in your OS. This is not recommended or supported. Can you provide more information about why you need to use a different version?

    Thank you.
     
  9. salvazo

    salvazo Member

    Joined:
    May 2, 2011
    Messages:
    14
    Likes Received:
    1
    Trophy Points:
    53
    Hi Michael, I need to use this settings from DOMDocument: LIBXML_HTML_NOIMPLIED | LIBXML_HTML_NODEFDTD

    And are only available on version 2.7.7:

    PHP: Predefined Constants - Manual
     
  10. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,419
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    The CentOS support forums are likely the best resource for help manually updating to a newer version of LibXML on your OS:

    CentOS - Index page

    Thank you.
     
Loading...

Share This Page