The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

update quota for package without resetting other settings

Discussion in 'General Discussion' started by kjg, Dec 14, 2007.

  1. kjg

    kjg Well-Known Member

    Joined:
    Mar 2, 2004
    Messages:
    147
    Likes Received:
    0
    Trophy Points:
    16
    Hi

    Have 5 different packages used when setting up accounts

    Have a lot of accounts with extra quota, extra databases etc compared to the package they have


    Now I want to update the packages. Simply doubling the quota for each package.

    The result íf I modify the package via "Edit packages" function in WHM is that all accounts are reset to the package settings. Not good, since a lot of accounts has extra quota, extra emails, databases etc.

    Ex: If I have changed "Max SQL Databases" to 5 for an account instead of standard 2 for the package it will be reset to 2 if I use the "Edit packages" function in WHM.

    This is not what I want.

    I suppose the only solution in this case would be to:

    1) Change package quota settings without updating all accounts
    2) Update account quotas per package and just adding the (new quota - old quota) to each account or updating quota separately

    Are there any scripts making this possible or any other ideas?

    Most important is to be able to change package qouta without updating all accounts.
     
  2. kjg

    kjg Well-Known Member

    Joined:
    Mar 2, 2004
    Messages:
    147
    Likes Received:
    0
    Trophy Points:
    16
    I think I have solved it

    1) change the setting for the packages in /var/packages/

    2) change the quota for each account in /etc/quota.conf (manually will do for now)

    Any comments on doing it this way? Any problems that might occur?


    **** edit ****
    Seems that changing the /etc/quota.conf will not change the settings for the accounts. It still shows up in WHM with old quota.
    Will hae to look for other solution
     
    #2 kjg, Dec 14, 2007
    Last edited: Dec 14, 2007
Loading...

Share This Page