The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

update-roundcube script - "Access Denied"

Discussion in 'E-mail Discussions' started by mofolo, Mar 1, 2012.

  1. mofolo

    mofolo Member

    Joined:
    Jan 26, 2012
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Hi Guys,

    I've recently received the Roundcube error:
    DATABASE ERROR: CONNECTION FAILED!

    I did a lot of googling and found that Roundcube needs InnoDB, so I removed skip-innoDB from my .cnf file;

    I then tried to run the update script, but it is returning this:

    Code:
    # /usr/local/cpanel/bin/update-roundcube --force
    mysqladmin: connect to server at 'localhost' failed
    error: 'Access denied for user 'root'@'localhost' (using password: YES)'
    Mysqld not running
    
    The error is clear because my root user has a password, this script cannot access the root user for my mysql. How can I specify my root's password?

    I search everywhere and couldn't find a solution. Any help would be appreciated.
     
    #1 mofolo, Mar 1, 2012
    Last edited: Mar 1, 2012
  2. mofolo

    mofolo Member

    Joined:
    Jan 26, 2012
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Seems like no-one can help me with this one.
     
  3. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,478
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Updating cPanel normally should update Roundcube as needed.
    What were you googling around for in the first place? What was the problem you were facing?
     
  4. mofolo

    mofolo Member

    Joined:
    Jan 26, 2012
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    As stated in the original post, roundcube will return with:

    Thanks.
     
  5. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,478
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Well, you said:

    So it was working before you added that line originally, or no? That line was not added by cPanel.

    Have you tried resetting your root MySQL password?

    WHM > SQL Services > MySQL Root Password
     
  6. mofolo

    mofolo Member

    Joined:
    Jan 26, 2012
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Yes, I commented out the line skip-innoDB after Googling that Roundcube runs off InnoDB.
    Restated mySQL and still got the same error.

    I went into my phpMyAdmin as root, all the Roundcube tables are marked as "in use".
     
  7. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,478
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    But was Roundcube running fine previous? I'm trying to understand how you got here to this issue. Is this the default installation of Roundcube available with cPanel or did you install your own copy of Roundcube?
     
  8. mofolo

    mofolo Member

    Joined:
    Jan 26, 2012
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    I had never tried it before hand, so I believe it never did work.
     
  9. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,478
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    If Roundcube is enabled via:
    WHM > Server Configuration > Tweak Settings, Mail tab:
    Enable RoundCube webmail
    (and you save at bottom of page)

    Try forcing a cPanel update:

    WHM > cPanel > Upgrade to Latest Version
     
  10. mofolo

    mofolo Member

    Joined:
    Jan 26, 2012
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Unfortunately it did not work.
    During the update I could see there were MySQL Access denied errors
     
  11. mofolo

    mofolo Member

    Joined:
    Jan 26, 2012
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Found the problem.

    The my.cnf has all these innodb lines which killed the Storage Engine, the lines where as follows:

    Code:
    innodb_file_per_table=1
    innodb_buffer_pool_size=512M
    innodb_additional_mem_pool_size=10M
    innodb_log_file_size=125M
    innodb_log_buffer_size=4M
    innodb_thread_concurrency=2
    I removed these lines and restarted mySQL, all is good now!

    Thanks for your help.
     
  12. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,478
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Tweaking the my.cnf file should not be taken lightly. Adding things that shouldn't be there can break stuff, as you now know. ;)

    Glad you got it sorted.
     
Loading...

Share This Page